calcul horaire avec écrêtement

olmadaco

XLDnaute Nouveau
Bonjour,

Je me suis confectionné un classeur me permettant de calculer mes horaires hebdomadaires et mensuels.
Je n'arrive pas à écrire une formule"si" indiquant que quand une cellule est supérieure à 09:00; si vrai 09:00; si faux valeur cellule.
En un mot, au delà de 9:00 par jour, le temps n'est plus pris en compte.
Quelqu'un pourrait-il m'aider?
Merci à l'avance
Olmadaco
 
G

Guest

Guest
Re : calcul horaire avec écrêtement

Bonsoir Olmadaco,

si l'heure est en A2 par exemple formule en B2:
Code:
=SI(TEMPS(HEURE(A2);MINUTE(A2);0)> TEMPS(9;0;0);TEMPS(9;0;0);A2)

Ou:

Code:
=SI(A2>0,375;0,375;A2)

0,375 représentant l'équivalent décimal de 9:00:00

bon Week-end
 

TheLio

XLDnaute Accro
Re : calcul horaire avec écrêtement

Hello,
Si ton total est en A1,
Edit : Oups un coup de fil, et déjà deux génies qui passent par là, >>> Bonsoir Pierrejean et Hasco

Edit 2Message édité, Erreur dans la formule :(
 
Dernière édition:
G

Guest

Guest
Re : calcul horaire avec écrêtement

Salut PierreJean,

J'ai essayé ta formule =SI(A1+B1<=9;A1+B1;9) et problème:

Si la somme est >9 elle me retourne le total. J'ai essayé de mettre FAUX à la place de 9 en 2ème valeur de retour de la formule... Idem, elle me retourne le total???????????? Bizzzard Non!?:cool:

Bonne soirée
 

pierrejean

XLDnaute Barbatruc
Re : calcul horaire avec écrêtement

Re

@ Hasco

Je voulais simplement mentionner le principe du =SI(......
Voila avec des formats d'heure
Le principe est toujours le même , seules changent les valeurs (rappel : pour Excel l'unité est le jour (24 heures) donc 9 heures =9/24 )
 

Pièces jointes

  • enheures.zip
    1.6 KB · Affichages: 36
G

Guest

Guest
Re : calcul horaire avec écrêtement

Merci PierreJean de ce rappel,

C'est pour cela qu'en deuxième formule, je lui propais '=SI(A2>0,375;0,375;A2)'. J'aurais du lui préciser qu'il s'agissait du 9/24ème du jour, cela lui aurait été utile ultérieurement.

bonne semaine à toi
 

Discussions similaires

Statistiques des forums

Discussions
312 017
Messages
2 084 634
Membres
102 623
dernier inscrit
eychenneanne