Calcul de la moyenne de temps écoulé entre les entrées

grandzorglub

XLDnaute Nouveau
Bonjour à tous!

Mon premier message sur ce forum qui me semble vraiment bien fait!

J'ai un problème qui est tout bête mais j'ai beau chercher, je ne trouve pas la solution...

Voilà :
Dans une tentative pour arrêter de fumer, j'ai décidé de commencer par mieux comprendre mes habitudes. J'entre donc l'heure de chacune des cigarettes que je fume. J'aimerais maintenant avoir la durée moyenne écoulée entre 2 cigarettes dans une journée. Le calcul est simple mais fastidieux :

Exemple :
=((entrée #2 - entrée #1)+(entrée #3 - entrée #2)+(entrée #4 - entrée #3))/3

Pour la division, pas de problème. Je fais, par exemple : =(NBVAL(D6:G6)-1)
Mais pour les entrées, c'est long!

Existe t-il une fonction qui me permettrait de ne pas avoir à rentrer les données une à la fois?

Merci!
 
Dernière édition:

Fred0o

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

Bonjour grandzorglub et bienvenue sur le forum.

Si tes données sont en A1:A4, utilises cette formule à valider par <Shift><Ctrl><Enter> (c'est une matricielle) :
Code:
=MOYENNE($A$2:$A$4-$A$1:$A$3)

A+
 

R@chid

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

Bonjour et Bienvenu sur XLD,
Voir si ça peut t'aider...
Amicalement

Edit : Salut Fred0o
 

Pièces jointes

  • Cigarettes.xls
    28 KB · Affichages: 64
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

Bonjour le Forum,
Bonjour grandzorglub,

Un essai en fichier joint

Cordialement

EDIT et pour faire bon poid bonne mesure une formule matricielle suivant mon fichier

Code:
=MOYENNE(SI((MOD(COLONNE(B2:G2);2)=0)*(MOD(COLONNE(A2:F2);2)=1)*1;B2:G2-A2:F2))

EDIT 1 : Bonjour FredOo:), Bonjour Rachid:)
 

Pièces jointes

  • grand.xlsx
    9.3 KB · Affichages: 50
Dernière édition:

grandzorglub

XLDnaute Nouveau
Re : Calcul de la moyenne de temps écoulé entre les entrées

Merci beaucoup Fred0o pour ta réponse! Malheureusement, ça me renvois une erreur de valeur.

J'envoie le fichier pour mieux voir ce qui ce passe.
 

Pièces jointes

  • dépenses inutiles.xlsx
    33.6 KB · Affichages: 53
  • dépenses inutiles.xlsx
    33.6 KB · Affichages: 56
  • dépenses inutiles.xlsx
    33.6 KB · Affichages: 64

R@chid

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

ReBonjour @ tous,

en R6,
Code:
=MOYENNE(SI(MOD(E$5:Q$5;2)=0;MOD(E6:Q6-D6:P6;1)))

Ou Bien plus joli,
Code:
=SI(NB(D6:Q6)=0;"AUCUNE";SI(MOD(NB(D6:Q6);2)=1;"Finis d'abord la cigarette";MOYENNE(SI(MOD(E$5:Q$5;2)=0;MOD(E6:Q6-D6:P6;1)))))


les 2 formules @ valider par Ctrl+Maj+Entree et @ tirer vers le bas
 

R@chid

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

Bonsoir @ tous,
Attention la formule de Fred0O et la mienne qui est en Post #7 ne renvoie pas le bon résultat,
voir la correction en Post #9, qui gère aussi le cas d'une cigarette commencer par exemple en 23:45 et finit en 00:10
Amicalement
 

Fred0o

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

Re-bonsoir à tous,

En effet,ma formule donne un résultat faux, au passage d'un jour sur l'autre (comme ta formule initiale, grandzorglub). Le MOD() introduit par R@chid et Jocelyn, permet d'avoir des valeurs justes.

A+
 

R@chid

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

Bonsoir @ tous,
Aussi la formule de notre ami Jocelyn ne gère pas le cas du passage d'un jour su l'autre...
Voir PJ
Amicalement
 

Pièces jointes

  • Cigarettes_Final.xlsx
    14.8 KB · Affichages: 78

Jocelyn

XLDnaute Barbatruc
Re : Calcul de la moyenne de temps écoulé entre les entrées

re,

Exact rachid, 2 soucis dans ma formule je n'ai pas gérer les cellules vides et pas gérer non plus les changements de jour ma formule :

Code:
=MOYENNE(SI((MOD(COLONNE(D5:P5);2)=0)*(MOD(COLONNE(C5:O5);2)=1)*1;D6:P6-C6:O6))

devient :

Code:
=MOYENNE(SI((MOD(COLONNE(D5:P5);2)=0)*(MOD(COLONNE(C5:O5);2)=1)*(D6:P6<>"");MOD(D6:P6-C6:O6;1)))

tout le soucis de créer un exemple à la va vite

J'aime beaucoup le clin d'oeil va finir ta cigarette :p
 

grandzorglub

XLDnaute Nouveau
Re : Calcul de la moyenne de temps écoulé entre les entrées

Alors là, je commence à croire que c'est plus compliqué que je ne le pensais au départ... ;)

Voilà, j'ai intégré les formules jusqu'à maintenant et il me semble que seule celle de Fred0o arrive à la bonne réponse (quoique je ne comprend pas pourquoi j'ai un négatif en ligne 6 et pas en 7???... probablement dû au changement de date dont je n'ai pas tenu compte)

Peut-être je me suis mal exprimé : je cherche à trouver le temps moyen qui sépare chaque cigarette une de l'autre (sans égard à la longueur de temps que ça prend pour la fumer, disons que j'entre l'heure une fois qu'elle est finit) Donc je ne devrais pas arriver à une valeur AM ou PM mais bien à valeur en minutes. Dans mon exemple : en moyenne 53 minutes entre chaque cigarette fumée)

Je ne tiens pas compte du changement de date à minuit car je ne veux pas que les heures où je dors entrent en ligne de compte.

Qu'en pensez-vous?
 

Pièces jointes

  • dépenses inutiles.xlsx
    33.6 KB · Affichages: 49
  • dépenses inutiles.xlsx
    33.6 KB · Affichages: 51
  • dépenses inutiles.xlsx
    33.6 KB · Affichages: 58

Discussions similaires

Réponses
5
Affichages
246

Statistiques des forums

Discussions
312 855
Messages
2 092 847
Membres
105 543
dernier inscrit
sebastien catenaire