calcul année+mois entre 2 dates

T

Tpl

Guest
Bonjour
J'essaie de calculer le nombre d'années + mois entre 2 dates par une formule simple (cf fichier joint)
le résultat n'est pas satisfaisant par rapport au nre de mois restant
Pourriez vous m'aider ?
En vous remerciant pour votre aide

Tpl
 

niki42

XLDnaute Occasionnel
salut tpl

en fichier joint tu trouveras des exemples avec les formules à utiliser

reviens sur le forum si tu ne comprends pas


[file name=tpl.zip size=1699]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/tpl.zip[/file]
 

Pièces jointes

  • tpl.zip
    1.7 KB · Affichages: 113
J

JC de Lorient

Guest
re le forum

formule améliorée qui évite les zéros !!

=SI(DATEDIF(A1;B1;'y')=0;'';DATEDIF(A1;B1;'y')&' ans ')&SI(DATEDIF(A1;B1;'ym')=0;'';DATEDIF(A1;B1;'ym')&' Mois ')&SI(DATEDIF(A1;B1;'md')=0;'';DATEDIF(A1;B1;'md')&' Jours ')


JC
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Et une qui gère les pluriels
=SI(A1='';'';SI(ET(DATEDIF(A1;B1;'y')=0;DATEDIF(A1;B1;'ym')=0;DATEDIF(A1;B1;'md')=0);0&' jour';SI(DATEDIF(A1;B1;'y')<>0;DATEDIF(A1;B1;'y')&SI(DATEDIF(A1;B1;'y')>1;' ans ';' an ');'')&SI(DATEDIF(A1;B1;'ym')<>0;DATEDIF(A1;B1;'ym')&' mois ';'')&SI(DATEDIF(A1;B1;'md')<>0;DATEDIF(A1;B1;'md')&SI(DATEDIF(A1;B1;'md')>1;' jours';' jour');'')))

(A1 = date de début et B1 = date de fin)
 

Gael

XLDnaute Barbatruc
Bonjour Tpl, Monique, niki, JC,

Et une dernière solution avec une macro complémentaire qui contient une fonction DIFFDATE qui gère la précision (année, mois, jours), et les pluriels.

la formule est très simple:

=DIFFDATE(D7;E7;3)

Date début en D7 et Date de fin en E7 puis précision souhaitée.

Adresse du téléchargement : Ce lien n'existe plus
nom de la macro: morefun.xll

@+

Gael
 
M

MERCI LE FORUM

Guest
Encore une fois j'ai été plus que aidé !!
Merci beaucoup tous et toutes .
Grâce à vos conseils je peux présenter mon doc sous une forme que je recherche depuis longtemps

Bonne journée et toujours beaucoup d'enthousiasme pour les coups de main !

Tple
 

Discussions similaires

Statistiques des forums

Discussions
300 718
Messages
1 986 643
Membres
209 555
dernier inscrit
Cookone