Microsoft 365 Aide sur formule excel

Cris_038

XLDnaute Nouveau
Bonjour la team,

J'ai besoin de vous pour avoir une petite routine sous excel répondant aux conditions suivantes fonction du fichier en annexe svp:

Développement pour afficher un état en cellule C2

1-Effectuer le contrôle - Si pas de date d'affectation dans la cellule A2 et pas de date de retour dans la cellule B2 alors faire remonter dans la cellule C2 l'information "01-AFFECTATION NON DEMARRE"
2-Effectuer le contrôle - Si pas de date d'affectation dans la cellule A2 et une date de retour dans la cellule B2 alors faire remonter dans la cellule C2 l'information "02-MANQUE DATE AFFECTATION"
3-Effectuer le contrôle - Si présence d'une date d'affectation dans la cellule A2 et pas de date de retour dans la cellule B2 alors faire remonter :
  • 3.1-Si différence entre F1 et A2 est strictement inférieur à I4 alors afficher 03-EN COURS DE PRODUCTION
  • 3.2-Si différence entre F1 et A2 est égal à I4 alors afficher 04-DLR EN RISQUE
  • 3.3-Si différence entre F1 et A2 est strictement supérieur à I4 alors afficher 04-DLR DEPASSEE
4-Effectuer le contrôle - Si présence d'une date d'affectation dans la cellule A2 et une date de retour dans la cellule B2 alors faire remonter :
  • 4.1-Si différence entre B2 et A2 est inférieur ou égale à I4 alors afficher 01-PRODUCTION REALISEE DANS LES DELAIS DE REF
  • 4.2-Si différence entre B2 et A2 est strictement supérieur à I4 alors afficher 02-PRODUCTION REALISEE EN DEHORS DES DELAIS DE REF
Merci bcp pour votre investissement




 

Pièces jointes

  • Test (2).xlsx
    9.4 KB · Affichages: 5

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer
VB:
=SI(ET(A2<1;B2<1);"01-AFFECTATION NON DEMARRE";SI(ET(A2<1;B2>1);"02-MANQUE DATE AFFECTATION";SI(ET(A2>1;B2<1);SI($F$1-$A2<$I$4;"03-EN COURS DE PRODUCTION";SI($F$1-$A2=$I$4;"04-DLR EN RISQUE";SI($F$1-$A2>$I$4;"04-DLR DEPASSEE";)));SI(ET(A2>1;B2>1);SI(B2-A2<=$I$4;"01-PRODUCTION REALISEE DANS LES DELAIS DE REF";SI(B2-A2>$I$4;"02-PRODUCTION REALISEE EN DEHORS DES DELAIS DE REF";));))))

Edit: Bonjour JJ68, désolé pas rafraichi avant de poster.

JHA
 

Pièces jointes

  • Test (2).xlsx
    9.7 KB · Affichages: 2

Cris_038

XLDnaute Nouveau
Merci. Je viens de tester - mais je pense qu'il manque un paramètre dans la formule car voici le résultat

1637241522946.png


Alors que nous devrions avoir "01-PRODUCTION REALISEE DANS LES DELAIS DE REF"
 

Cris_038

XLDnaute Nouveau
Bonjour à tous,

A essayer
VB:
=SI(ET(A2<1;B2<1);"01-AFFECTATION NON DEMARRE";SI(ET(A2<1;B2>1);"02-MANQUE DATE AFFECTATION";SI(ET(A2>1;B2<1);SI($F$1-$A2<$I$4;"03-EN COURS DE PRODUCTION";SI($F$1-$A2=$I$4;"04-DLR EN RISQUE";SI($F$1-$A2>$I$4;"04-DLR DEPASSEE";)));SI(ET(A2>1;B2>1);SI(B2-A2<=$I$4;"01-PRODUCTION REALISEE DANS LES DELAIS DE REF";SI(B2-A2>$I$4;"02-PRODUCTION REALISEE EN DEHORS DES DELAIS DE REF";));))))

Edit: Bonjour JJ68, désolé pas rafraichi avant de poster.

JHA
Merci. On y est presque - je viens de tester la formule mais l'état n'est pas le bon dans le cadre suivant :

4.2-Si différence entre B2 et A2 est strictement supérieur à I4 alors afficher 02-PRODUCTION REALISEE EN DEHORS DES DELAIS DE REF


1637241679486.png
 

Discussions similaires

Réponses
2
Affichages
228
Réponses
10
Affichages
271

Statistiques des forums

Discussions
312 884
Messages
2 093 248
Membres
105 658
dernier inscrit
Mario Richard