Microsoft 365 aide index equiv ou si

mohcine_5

XLDnaute Nouveau
Bonjour ,
je voudrais trouver une formule dans la feuille OP J COLONNE A qui va me permettre de connaitre si la date de la colonne B est correct ou pas par rapport a la feuille OP J-1 et ca en se référant aux critère en jaune.
donc si il trouve les même critère en jaune dans la feuille OP J-1 il prend la date dans la colonne A OP J-1 sinon il met la date de la feuille OP J colonne C .
ou si un expert en VBA qui pourrait aider
Merci beaucoup pour votre AIDE
 
Dernière édition:

Softmama

XLDnaute Accro
Bonjour mohcine_5 et bienvenu,

cette formule en cellule A2 à tester ?
VB:
=SI(E2&F2&G2&H2&I2&M2='OP J-1'!D2&'OP J-1'!E2&'OP J-1'!F2&'OP J-1'!G2&'OP J-1'!H2&'OP J-1'!L2;'OP J-1'!A2;'OP J'!C2)

cf. fichier joint,

Bien cordialement,
 

Pièces jointes

  • CO.xls
    296.5 KB · Affichages: 8

mohcine_5

XLDnaute Nouveau
Merci infiniment ca marche à merveille
Bonjour , normalement ca marche pas si une ligne n’existe pas on doit toujours avoir le meme ordre chronologique et ca biase le résultat
Bonjour mohcine_5 et bienvenu,

cette formule en cellule A2 à tester ?
VB:
=SI(E2&F2&G2&H2&I2&M2='OP J-1'!D2&'OP J-1'!E2&'OP J-1'!F2&'OP J-1'!G2&'OP J-1'!H2&'OP J-1'!L2;'OP J-1'!A2;'OP J'!C2)

cf. fichier joint,

Bien cordialement,
Bonjour ,
ca ne marche pas si l'ordre est pas chnorlogique ou des lignes disparaissenet j'ai essayé ca mais sans resultat :
=SI(ou(E2&F2&G2&H2&I2&M2='OP J-1'!D2&'OP J-1'!E2&'OP J-1'!F2&'OP J-1'!G2&'OP J-1'!H2&'OP J-1'!L2 ;'OP J-1'!D3&'OP J-1'!E3&'OP J-1'!F3&'OP J-1'!G3&'OP J-1'!H3&'OP J-1'!L3 ;'OP J-1'!D4&'OP J-1'!E4&'OP J-1'!F4&'OP J-1'!G4&'OP J-1'!H4&'OP J-1'!L4 ;'OP J-1'!D5&'OP J-1'!E5&'OP J-1'!F5&'OP J-1'!G5&'OP J-1'!H5&'OP J-1'!L5;'OP J-1'!D6&'OP J-1'!E6&'OP J-1'!F6&'OP J-1'!G6&'OP J-1'!H6&'OP J-1'!L6;'OP J-1'!D7&'OP J-1'!E7&'OP J-1'!F7&'OP J-1'!G7&'OP J-1'!H7&'OP J-1'!L7;'OP J-1'!D8&'OP J-1'!E8&'OP J-1'!F8&'OP J-1'!G8&'OP J-1'!H8&'OP J-1'!L8;'OP J-1'!D9&'OP J-1'!E9&'OP J-1'!F9&'OP J-1'!G9&'OP J-1'!H9&'OP J-1'!L9;'OP J-1'!D10&'OP J-1'!E10&'OP J-1'!F10&'OP J-1'!G10&'OP J-1'!H10&'OP J-1'!L10 ;'OP J-1'!A2;'OP J'!C2))

il me donne une erreur
 

Statistiques des forums

Discussions
312 836
Messages
2 092 618
Membres
105 467
dernier inscrit
ALLAIN 35