Microsoft 365 affichage données sous condition et impression en .PDF

pilotebien

XLDnaute Nouveau
Bonjour,

je bloque sur une fonction. Mon soucis est que j'ai recherché sur le forum et sur des moteurs de recherches mais je ne trouve pas mon bonheur.

Je souhaite sur l'onglet [Fiche_Recep] choisir le personnel par un menu déroulant.
Ensuite et automatiquement je souhaite faire apparaitre dans le tableau la liste des matériels et quelques infos piochées dans l'onglet [Inventaire].

Edit 14/05/2021: actuellement, je fais un copier/coller de la base [inventaire] et par le biais de la fonction RECHERCHEV je remplis mes colonnes.

Comment peut on faire disparaitre les 0 dans les colonnes ou le cas échéant remplacé le 0 par néant?

Enfin, je souhaite une fois saisie ces infos, imprimer en PDF cette fiche avec :
- nom de l'agent,
- date,
- heure
- position de la fiche (perception/réintégration).

Edit 14/05/2021:
Est il possible que la hauteur des lignes s'adaptent au contenu?

J'ai mis a jour le fichier .

Merci par avance pour votre aide et conseil.
Si vous voyez des améliorations ou incohérences merci de m'en faire un retour.
Cordialement,
 

Pièces jointes

  • XLD_GestMatETL.xlsm
    244.4 KB · Affichages: 15
Dernière édition:
Solution
Bonjour pilotebien, fanch55, le forum

pour tes 0 une petite modif de formule suffira
=SI(RECHERCHEX(A6;Inventaire!$B$8:$B$150;Inventaire!$P$8:$P$150)=0;"";RECHERCHEX(A6;Inventaire!$B$8:$B$150;Inventaire!$P$8:$P$150))

pour forcer les hauteurs de lignes, après un recalcul, passer le code
VB:
    Rows("6:21").RowHeight = 100
    Rows("6:21").EntireRow.AutoFit

Bien cordialement, @+

Bernard_XLD

XLDnaute Barbatruc
Membre du Staff
Bonjour pilotebien, fanch55, le forum

pour tes 0 une petite modif de formule suffira
=SI(RECHERCHEX(A6;Inventaire!$B$8:$B$150;Inventaire!$P$8:$P$150)=0;"";RECHERCHEX(A6;Inventaire!$B$8:$B$150;Inventaire!$P$8:$P$150))

pour forcer les hauteurs de lignes, après un recalcul, passer le code
VB:
    Rows("6:21").RowHeight = 100
    Rows("6:21").EntireRow.AutoFit

Bien cordialement, @+
 
Dernière édition:

Bernard_XLD

XLDnaute Barbatruc
Membre du Staff
Re,

et aussi, je crois que la pièce jointe contient des données confidentielles dans l'onglet liste (des noms et prénoms de personnes réelles).
Merci, si c'est le cas, de supprimer rapidement le fichier et de l'anonymiser avant de le reposter, et si ce n'est pas le cas, de préciser que les noms et prénoms sont ceux de personnes fictives.
voici le lien vers la charte du forum, il est important de la respecter
J'ai averti l'administrateur du site.

Bien cordialement, @+
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
313 309
Messages
2 097 032
Membres
106 812
dernier inscrit
Excellou74