XL 2019 Affichage Calcul multiple

hemardjean

XLDnaute Occasionnel
Bonjour le forum

Je me tourne à nouveau vers vous car je ne trouve pas la formule de calcul qu'il me faudrait. Je vais vous exposer mon problème.

  • j'ai la cellule C16, qui additionne mes cellules C3+C7+C11
  • puis la cellule C17, qui additionne les cellules C4+C8+C12
  • puis la cellule C18, qui additionne les cellules C5+C9+C12
  • puis en cellule C19 ,C20, C21 j'ai placé la formule suivante pour ranger mes calculs par ordre
=SI(ET(ESTNUM(C16);C16>0);RANG(C16;$C$16:$AK$16;0);"")

et en cellule C22,C23 ,C24 la formule suivante pour me donner une note par rapport à mon classement précédent

=SI(C19=1;"25";SI(C19=2;"20";SI(C19=3;"15";SI(C19=4;"10";SI(C19=5;"5";SI(C19=6;"0";""))))))

  • puis en cellule C25 l'addition des cellules C22,C23 ,C24
  • et pour finir en cellule C26 l'addition/3
Mon problème est le suivant si toutes les cellules ne sont pas remplies mon calcul ne se fait pas et moi je cherche à faire le calcul en C26 sans que toutes les cellules de la C3 à la C13 soient remplies.

Je vous joins une feuille de calcul car les explications que je donne ne sont pas trop clair.

Merci de votre aide

Bien cordialement
 

Pièces jointes

  • 3 échanti de dégustation.xlsx
    12.7 KB · Affichages: 17

hemardjean

XLDnaute Occasionnel
Bonsoir le forum,sousou
Je me suis trop précipité
en cellule C25 et C26 j'ai mis le calcul pour additionner en C25 et diviser par 3 en C26 mais je m’aperçois que la somme n'est pas correcte car lorsque je n'ai qu'une cellule il ne devrait pas me le diviser mais m'afficher le calcul simple et lorsqu’il y a 2 calcul me diviser par 2 .
Quelle fonction il me faudrait utiliser pour faire les trois formes d'addition puis la division par 2 ou par 3.
Merci
 

hemardjean

XLDnaute Occasionnel
bonjour sousou
merci de ta réponse après intégration dans mon document ta formule fonctionne mais je me trouve confronté maintenant lorsque je supprime toutes les cellules pour les mettre à zéro avec un faux qui s'affiche dans les cellules c22 a C24 ou tu m'avais placé la formule suivante =SI(C19=0;0;SI(C19=1;25;SI(C19=2;20;SI(C19=3;15;SI(C19=4;10;SI(C19=5;5;SI(C19=6;0)))))))

j'avais ajouté à la fin de ta formule ;"") mais ça ne fonctionne pas.
 

hemardjean

XLDnaute Occasionnel
Bonjour sousou,bonjour le forum
serait-il possible de combiner l'ancienne formule
=SIERREUR(C52/(3-NB.SI(C49:C51;0));"")
qui affichai le "faux" car elles me divisaient bien la cellule du dessus ,ou par 0 ou par 2 ou par 3
avec la dernière qui elle me supprimer le" faux"
=SI(C52<>0;SIERREUR(C52/3-(NB.SI(C49:C51;0));"");"")
mais ne divise ma cellule que par trois.
 

Discussions similaires

Réponses
8
Affichages
361
Réponses
5
Affichages
261

Statistiques des forums

Discussions
312 935
Messages
2 093 741
Membres
105 805
dernier inscrit
belgacem.nahali