XL 2021 Valeur unique sur plusieurs colonnes

Rabeto

XLDnaute Occasionnel
Bonjour à tous,

Je vous partage un fichier dont je souhaite faire une :

- Extraction des valeurs uniques sur 2 colonnes C et D (Si possible de mettre une explication si j'ai 3 colonnes à extraire ou plus)

J'ai utilisé la fonction unique mais ça ne marche pas

merci d'avance
 

Pièces jointes

  • Valeur unique.xlsx
    11.2 KB · Affichages: 8
Solution
Bonjour,

En E3, mettre la formule matricielle suivante
VB:
=SIERREUR(INDEX($C$3:$C$13;EQUIV(0;NB.SI(E$2:E2;$C$3:$C$13);0));SIERREUR(INDEX($D$3:$D$13;EQUIV(0;NB.SI(E$2:E2;$D$3:$D$13);0));""))

A valider par CTRL+MAJ+ENTREE et recopier vers le bas ;)

wDog66

XLDnaute Occasionnel
Bonjour,

En E3, mettre la formule matricielle suivante
VB:
=SIERREUR(INDEX($C$3:$C$13;EQUIV(0;NB.SI(E$2:E2;$C$3:$C$13);0));SIERREUR(INDEX($D$3:$D$13;EQUIV(0;NB.SI(E$2:E2;$D$3:$D$13);0));""))

A valider par CTRL+MAJ+ENTREE et recopier vers le bas ;)
 

Gégé-45550

XLDnaute Accro
Bonjour à tous,

Je vous partage un fichier dont je souhaite faire une :

- Extraction des valeurs uniques sur 2 colonnes C et D (Si possible de mettre une explication si j'ai 3 colonnes à extraire ou plus)

J'ai utilisé la fonction unique mais ça ne marche pas

merci d'avance
Bonjour,
VB:
=TRANSPOSE(TRIER(UNIQUE(ASSEMB.V(FILTRE(C3:C13;C3:C13<>"");FILTRE(D3:D13;D3:D13<>""));FAUX);1;1))
[EDIT] PJ modifiée à 14:23 [/EDIT]
Cordialement,
 

Pièces jointes

  • Valeur unique.xlsx
    19.1 KB · Affichages: 0
Dernière édition:

Gégé-45550

XLDnaute Accro
Merci pour vos réponses,

la réponse Gégé-45550 de me donne ça _xlfn.VSTACK à la place de ASSEMB.V quand je telecharge le fichier,
Même si je prends la formule et le colle dans un autre fichier
Désolé,
J'étais sûr que 2021 gérait aussi cette fonction mais après vérification, elle n'est prise en charge que par 365 et Excel pour le WEB.
Sorry,
 

Discussions similaires

Statistiques des forums

Discussions
313 323
Messages
2 097 153
Membres
106 854
dernier inscrit
Alex_Touge