urgent svp nb.si et sous.total

Marie-Claire

XLDnaute Junior
Bonjour,

J'ai vraiment besoin d'aide.

Voici un document joint.

Je cherche à faire un trie sur la colonne C pour '' J. Charron '' et les sous-total en bas pour la cellule c15 me donne le total de tout les lignes même ceux filtré.

J'aimerais dans la cellule c14 avoir seulement les MA affiché et ainsi de suite pour C15(SR)....

Merci beaucoup pour votre aide rapide....
 

Pièces jointes

  • Classeur2.xls
    13.5 KB · Affichages: 74
  • Classeur2.xls
    13.5 KB · Affichages: 69
  • Classeur2.xls
    13.5 KB · Affichages: 75

JCGL

XLDnaute Barbatruc
Re : urgent svp nb.si et sous.total

Bonjour à tous,
Edition : Bienvenue sur XLD :)

Ici, rien n'est urgent...
Une recherche sur le Forum t'aurait donné ceci.

A+ à tous
 

Pièces jointes

  • JC Classeur2.xls
    14.5 KB · Affichages: 70
  • JC Classeur2.xls
    14.5 KB · Affichages: 72
  • JC Classeur2.xls
    14.5 KB · Affichages: 75
Dernière édition:

Marie-Claire

XLDnaute Junior
Re : urgent svp nb.si et sous.total

Bonjour à tous,
Edition : Bienvenue sur XLD :)

Ici, rien n'est urgent...
Une recherche sur le Forum t'aurait donné ceci.

A+ à tous

Merci beaucoup !

J'avais fais vraiment quelques vérifications sur le site, mais je ne trouvais pas ceci.

Parcontre pourrais-tu me dire ton -5 fait référence à quoi, car j'essaie de recopier ta formule dans mon vrai dossier et cela ne fonctionne pas......je remplace tes B6 et B100 et B3 par ma vrai cellule..mais ton -5 je ne sais pas par quoi le remplacer.....merci encore pour ta patience malgrer que je sois encore novice....

=SOMMEPROD((SOUS.TOTAL(3;DECALER($B$6;LIGNE($B$6:$B$100)-5;)))*($B$6:$B$100=B3))
 

hoerwind

XLDnaute Barbatruc
Re : urgent svp nb.si et sous.total

Bonjour, salut JCGL,

La formule de JCGL légèrement modifiée pour que tu n'aies plus à te préoccuper du -5 :
C2 :
Code:
=SOMMEPROD((SOUS.TOTAL(3;DECALER($B$5;LIGNE($1:$95);)))*($B$6:$B$100=B2))
Cette formule peut être copiée en C3 sans y apporter de modification.

Remarque importante :
Sous les formules matricielles, la taille des plages doit être identique, de là 1:95 et 6:100, deux plages de 95 lignes.
Ces plages peuvent être adaptées suivant ton besoin, mais doivent rester de taille identique.
 

JCGL

XLDnaute Barbatruc
Re : urgent svp nb.si et sous.total

Bonjour à tous,

Tu auras remarqué que j'ai placé le "tableau récapitulatif" au dessus des données, c'est à mon sens plus logique et cela permet des données sur cent lignes avec la formule.

Le - 5 correspond au nombre de ligne qui sépare la cellule de la formule du début du tableau de données (les entêtes avec le filtre).

Dans mon fichier et pour permettre la recopie en C2 et C3 avec la même formule :
Code:
=SOMMEPROD((SOUS.TOTAL(3;DECALER($B$6;LIGNE($B$6:$B$100)+LIGNE()-8;)))*($B$6:$B$100=B2))
Comme la formule est en ligne 2, LIGNE()-8 donne -6
La même formule en ligne 3 donne -5

A+ à tous

Édition : Salut Hoerwind
 
Dernière édition:

Marie-Claire

XLDnaute Junior
Re : urgent svp nb.si et sous.total

Bonjour, salut JCGL,

La formule de JCGL légèrement modifiée pour que tu n'aies plus à te préoccuper du -5 :
C2 :
Code:
=SOMMEPROD((SOUS.TOTAL(3;DECALER($B$5;LIGNE($1:$95);)))*($B$6:$B$100=B2))
Cette formule peut être copiée en C3 sans y apporter de modification.

Remarque importante :
Sous les formules matricielles, la taille des plages doit être identique, de là 1:95 et 6:100, deux plages de 95 lignes.
Ces plages peuvent être adaptées suivant ton besoin, mais doivent rester de taille identique.


Promis ce sera la dernière fois que je vous dérange...

Je vous remet mon fichier mes avec les vrai lignes aux endroit réel de mon classeur originale.....

Merci milles fois !!!!
 

Pièces jointes

  • Classeur3.xls
    28 KB · Affichages: 69
  • Classeur3.xls
    28 KB · Affichages: 63
  • Classeur3.xls
    28 KB · Affichages: 58
C

Compte Supprimé 979

Guest
Re : [URGENT] NON de NON

Mon cher JC tu es trop bon :eek:

Quand est-ce que les gens cesseront de demander en URGENCE :mad:

J'espère pour toi, Marie-claire, que le trépas ne ce fera pas en URGENCE
sinon DOOOOOOOOOOMMMMMMMMMMAAAAAAAGGGGGGEEEEEEEEEE

sontfous.gif
 
C

Compte Supprimé 979

Guest
Re : urgent svp nb.si et sous.total

Dure NON
seulement réaliste :rolleyes:

Si tout est URGENT que devient le monde :confused:

Mais bon c'est ma réflexion de 20h15
Tiens le forum à 4 minutes de retard .. zut alors :D
 

hoerwind

XLDnaute Barbatruc
Re : urgent svp nb.si et sous.total

Re,

Vois la correction sous la pièce jointe.

Donne-toi la peine de consulter l'aide MS au sujet de la fonction DECALER, tu comprendras le pourquoi.
 

Pièces jointes

  • CalculSurFiltre.zip
    5.1 KB · Affichages: 26

Marie-Claire

XLDnaute Junior
Re : urgent svp nb.si et sous.total

Re,

Vois la correction sous la pièce jointe.

Donne-toi la peine de consulter l'aide MS au sujet de la fonction DECALER, tu comprendras le pourquoi.

Merci beaucoup ! Et compte sur moi pour aller vérifier sur l'aide un soir cette semaine....

Mais j'aurais tellement aimé te dire que tout fonctionne mais....lorsque je fais la sélection sur consentino, la base MI est inexacte...il inscrit 17 alors que ce devrait être 19...hummm pas facile.....Le reste fonctionne....

Merci
 

Discussions similaires

Réponses
4
Affichages
370
L
Réponses
3
Affichages
597
LeGrosMatou
L

Membres actuellement en ligne

Statistiques des forums

Discussions
312 913
Messages
2 093 535
Membres
105 752
dernier inscrit
fred13340