Trouver la 1er valeur supérieur à X

Jonathan

XLDnaute Nouveau
Bonjour à tous,

Existe t'il une fonction ou astuce permettant de trouver la 1ere valeur supérieure à une date ou valeur numéraire.

Par exemple, en colonne A, j'ai les dates du 01/01/2012 au 31/12/2012, avec plusieurs dates aléatoires absentes, et mon souhait en B1 et de retrouver une date, mais si celle-ci est absente en colonne A, alors de renvoyer la 1ere date supérieur à celle ci (et non la plus grande date inférieur à la date recherché comme le propose rechercheV)



Ex : si le 15/03/2012 est absent renvoyer la prochaine date disponible en colonne A, c'est à dire le 19/03/2012

....
10/03/2013
11/03/2013
12/03/2013
13/03/2013
14/03/2013
19/03/2013
20/03/2013
.....

ça pourrait m'étre utile dans pas mal de formule

merci
 

Modeste

XLDnaute Barbatruc
Re : Trouver la 1er valeur supérieur à X

Bonjour,

Si tes dates en colonne A sont classées par ordre croissant, ceci pourrait fonctionner, me semble-t-il:
Code:
 ... supprimé ...

Edit: comme me le signalait Jocelyn (merci à lui!) si la date cherchée existe en colonne A, ma formule renverra la suivante tout de même! Oubliez donc ma proposition.
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re : Trouver la 1er valeur supérieur à X

Bonjour le Forum,
Bonjour Jonathan,

un essai en fichier joint

Cordialement

EDIT : Oup's pas rafraichi, Bonjour l'ami modeste :), content de te croiser:)
 

Pièces jointes

  • jonathan.xls
    13.5 KB · Affichages: 42
  • jonathan.xls
    13.5 KB · Affichages: 49
  • jonathan.xls
    13.5 KB · Affichages: 46

Jonathan

XLDnaute Nouveau
Re : Trouver la 1er valeur supérieur à X

Bonjour les amis,

Ta proposition réponds bien, juste le faite que ce soit une formule matricielle qui m’embête un peu,
Je suis étonné que Excel ne propose pas nativement une formule, autrement je passe du coté VBA pour creer la fontion.

Edit : une autre solution mais qui manque de finesse :

Code:
=SI(ESTNA(RECHERCHEV(B1;A:A;1;0));GRANDE.VALEUR(A:A;RANG(RECHERCHEV(B1;A:A;1;1);A:A)-1);RECHERCHEV(B1;A:A;1;0))
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 849
Messages
2 092 797
Membres
105 534
dernier inscrit
EmilieG60