XL 2016 statistiques

marc94600

XLDnaute Occasionnel
Bonjour tout le monde,
tout d’abord merci pour votre aide.
Je souhaiterai mettre en place un système de statistique dans mon tableau Excel mais je suis confronter à 2 problèmes :
  1. Dans mon tableau feuille statistique, colonne A ligne 6 : ma formule est : =NB.SI(HPM_ARCHIVES!AM:AM;2023) or, 2023 n'est pas reconnu car il s'agit d'une date inversée (01/03/2024 donne 20240301) or j'ai besoin d'écrire cette date de cette manière et en mêm temps je voudrai savoir le nombre de fois que j'ai 2023, 2024...
  2. colonne E ligne 11, j'ai installé une liste déroulante,comment puis obtenir une formule pour comptabiliser le nombre de personne traiter en 2023, 2024... pour une société définie en E11
merci encore
marc
 

Pièces jointes

  • MARC DER.xlsx
    45.9 KB · Affichages: 2
Solution
Bonjour à tous,

Un début à adapter
VB:
=SOMME(--(GAUCHE(HPM_ARCHIVES!$AM$2:$AM$27;4)=TEXTE(A$5;"0000")))
Code:
=SOMMEPROD(('En cours à partir de 2019'!$B$2:$B$19=$E$11)*(GAUCHE('En cours à partir de 2019'!$U$2:$U$19;4)=TEXTE(STATISTIQUES!$D12;"0000")))

JHA

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un début à adapter
VB:
=SOMME(--(GAUCHE(HPM_ARCHIVES!$AM$2:$AM$27;4)=TEXTE(A$5;"0000")))
Code:
=SOMMEPROD(('En cours à partir de 2019'!$B$2:$B$19=$E$11)*(GAUCHE('En cours à partir de 2019'!$U$2:$U$19;4)=TEXTE(STATISTIQUES!$D12;"0000")))

JHA
 

Pièces jointes

  • MARC DER (1).xlsx
    46.2 KB · Affichages: 3

marc94600

XLDnaute Occasionnel
J'ai rectifié la colonne entière par une délimitation .
Mais j'obtiens tyoujours le même résultat. En revanche, c'est quoi la validation en matriciel?
J'ai essayé comme tu me l'as demandé (Ctrl+Maj+Entrée) mais pas de résultat
 

Statistiques des forums

Discussions
312 557
Messages
2 089 593
Membres
104 215
dernier inscrit
Jean Michl