Statistiques concernant la vente de terrains et de terres

belga

XLDnaute Nouveau
Bonjour à vous,
N'étant pas un expert en la matière, je me vois dans l'obligation de faire appel à des connaisseurs.
Voici le problème :
Dans ce chiffrier, je compile des données concernant des terrais à vendre ou vendus et je désire automatiser la section "A VENDRE DEPUIS (DATE)" et "NOMBRE DE JOURS".
Comme vous le verrez dans le fichier joint, lorsqu'on inscrit une date elle se transforme en un nombre et aussi lorsqu'il n'y a pas de date indiquée, dans la cellule s'inscrit un nombre de jours inconnu pour moi.
J'aimerai que les cellules sans données (date ou nombre de jours) restent à zéro quand je n'y insère pas de données. Aussi que les date ne se transforme pas en un nombre mais s'affichent en format date. Notez que les dates ici au Canada s'inscrivent à l'envers soit : 2013-01-25 et non 25-01-2013.
Quant au nombre de jours, ce serait parfait si les cellules dont il n'y a pas de date qui s'y rapporte, restent à zéro. Ceci pour que la moyenne se calcule justement au bas de la colonne.
Je pense que vous comprendrez mon idée de conception et que vous aurez la solution.
Mille mercis pour votre aide !!!
John
 

Pièces jointes

  • Test_terres#1.xlsx
    24 KB · Affichages: 45
  • Test_terres#1.xlsx
    24 KB · Affichages: 42
  • Test_terres#1.xlsx
    24 KB · Affichages: 48
Dernière édition:

kjin

XLDnaute Barbatruc
Re : Statistiques concernant la vente de terrains et de terres

Bonsoir,
Regarde les différents formats de cellules
Par contre je ne vois pas ce que tu entends par moyenne de temps

Edit : salut Chalet
A+
kjin
 

Pièces jointes

  • belga.xls
    50 KB · Affichages: 44

belga

XLDnaute Nouveau
Re : Statistiques concernant la vente de terrains et de terres

Merci mon ami,
Le résultat est super !!!
Un dernier point : pour les "vendus", comment faire que les résultats soient pareils que les "à vendre" ?
En ce qui concerne les moyennes de temps, j'ai annulé la case de la moyenne car elle n'a pas de sens ;o)))
Un gros merci !!! C'est très gentil de me répondre aussi rapidement. J'espère pouvoir te rendre service dans... un autre domaine un jour.
(je joins le fichier "copie de belga")
John
 

Pièces jointes

  • Copie de belga.xlsx
    24.3 KB · Affichages: 35

belga

XLDnaute Nouveau
Re : Statistiques concernant la vente de terrains et de terres

Merci beaucoup pour ta réponse.
C'est parfaitement programmé.
Un dernier point : comment enlever le ",0" au résultat moyen des jours ?
Merci, merci, merci !!!
John
 

Modeste geedee

XLDnaute Barbatruc
Re : Statistiques concernant la vente de terrains et de terres

Bonsour®
Un dernier point : pour les "vendus", comment faire que les résultats soient pareils que les "à vendre" ?
pour calculer des jours, il faut d'abord saisir des dates...
donc scinder les colonnes :

À VENDRE DEPUIS… (JOURS) VENDU EN… (JOURS)

en

Capture.JPG
 

Pièces jointes

  • Capture.JPG
    Capture.JPG
    21.7 KB · Affichages: 73
  • Capture.JPG
    Capture.JPG
    21.7 KB · Affichages: 72

belga

XLDnaute Nouveau
Re : Statistiques concernant la vente de terrains et de terres

Bonsoir,
En fait, voici le fichier en entier.
Il reste seulement à enlever "#DIV/0" dans les cellules de résultat lorsqu'il n'y a pas de données inscrites dans les cellules de la colonne. Je n'y parviens pas !!!
Le reste, avec toutes vos réponses, j'y suis arrivé.
Merci beaucoup, beaucoup !!!
John
 

Pièces jointes

  • Test_terres#1.xlsx
    25.5 KB · Affichages: 36
  • Test_terres#1.xlsx
    25.5 KB · Affichages: 40
  • Test_terres#1.xlsx
    25.5 KB · Affichages: 40

R@chid

XLDnaute Barbatruc
Re : Statistiques concernant la vente de terrains et de terres

Bonjour @ tous,
belga à dit:
Il reste seulement à enlever "#DIV/0" dans les cellules de résultat lorsqu'il n'y a pas de données inscrites dans les cellules de la colonne. Je n'y parviens pas !!!
Code:
=SIERREUR(SOMME(BK3:BK9)/NB.SI(BK3:BK9;">0");"")
ou bien plus simple,
Code:
=SIERREUR(MOYENNE.SI(BK3:BZ9;">0");"")


je ne voie pas quel est l’intérêt de toutes les cellules fusionnées.

@ +
 

belga

XLDnaute Nouveau
Re : Statistiques concernant la vente de terrains et de terres

Bonjour,
Merci pour toute cette aide. Mon truc fonctionne parfaitement maintenant.
L'intérêt de ce document est de créer des statistiques concernant l'immobilier et en particulier pour la vente de terres boisées ou de terrains à bâtir. C'est uniquement pour me faciliter la tâche.
Encore merci !!!
John
 

Modeste geedee

XLDnaute Barbatruc
Re : Statistiques concernant la vente de terrains et de terres

Bonsour®
Je ne saisis pas "cellules fusionnées".
Je te rappelle que je suis un cancre dans Excel !!!

:rolleyes:
ce sera alors l'occasion d'apprendre...

en pièce jointe :
Réorganisation,
Suppression des cellules fusionnées
Utilisation centrage sur plusieurs colonnes quand nécessaire
Suppression des principaux affichages d'erreur
Mise en forme conditionnelle pour saisies manquantes
 

Pièces jointes

  • Test_terres (2).xlsx
    24.3 KB · Affichages: 34

Discussions similaires

Statistiques des forums

Discussions
312 848
Messages
2 092 787
Membres
105 534
dernier inscrit
EmilieG60