Sommeprod plages dynamiques

Vilain

XLDnaute Accro
Salut à tous,

Je souhaite faire quelque chose que j'ai déjà fait mais que je ne parviens pas à reproduire...
Voici ma formule :
=SOMMEPROD(($B$9=Base!$AC$2:$AC$1900)*1)
Le souci vient du fait que ma base de données ne comporte pas toujours le même nombe de lignes et que je souhaiterai donc rentre cela dynamique.
Je suis sur que la solution se trouve du côté de la fonction decaler mais je n'arrive pas à la rédiger.

Merci d'avance.

A plus
 

Jocelyn

XLDnaute Barbatruc
Re : Sommeprod plages dynamiques

re,

Alors peut être en passant par un indirect de cette façon si valeur numérique en AC

Code:
=SOMMEPROD(($B$9=indirect("Base!$AC$2:$AC$"&equiv(recherche(10^9;Base!$AC$:$AC$);Base!$AC$:$AC$;0)))*1)

et pour valeur alpha en AC

Code:
=SOMMEPROD(($B$9=indirect("Base!$AC$2:$AC$"&equiv(recherche("zzz";Base!$AC$:$AC$);Base!$AC$:$AC$;0)))*1)

testes et dis nous

EDIT correction de formule
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re : Sommeprod plages dynamiques

re,

hum hum oui le equiv prend le premier qu'il trouve donc mauvaise solution, une autre par sommeprod() validé matriciellement

Code:
=SOMMEPROD(($B$9=INDIRECT("Base!$AC$2:$AC$"&MAX(SI(base!$AC$2:$AC$10000=$B$9;LIGNE(base!$AC$2:$AC$10000)))))*1)

un fichier exemple en plus
 

Pièces jointes

  • Gillus.xls
    13.5 KB · Affichages: 105
  • Gillus.xls
    13.5 KB · Affichages: 108
  • Gillus.xls
    13.5 KB · Affichages: 114

Discussions similaires

Réponses
12
Affichages
309

Membres actuellement en ligne

Statistiques des forums

Discussions
312 913
Messages
2 093 535
Membres
105 752
dernier inscrit
fred13340