somme et classement selon critères

apb

XLDnaute Occasionnel
Bonjour à tous

D'avance je vous remercie pour l'attention que vous pourrez porter à mon problème.

Je dois établir de façon dynamique un classement de participants à un concours.

Dans la feuille 1 je saisie les temps et points de pénalité de chaque participant de chaque équipe.

Dans la feuille 2 je voudrais réaliser un classement individuel dynamique des participants

Dans la feuille 3 je voudrais faire le classement dynamique des équipes (tous les participants ne sont pas en équipes) sachant que je ne dois prendre que les 3 meilleurs participant de chaque équipe en tenant compte des points de pénalités et du temps



Ci-joint un fichier qui j'espère vous permettra de comprendre mon problème.


Merci encore pour votre aide

APB [file name=essai apb_20050524130601.zip size=4133]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/essai apb_20050524130601.zip[/file]
 

Pièces jointes

  • essai apb_20050524130601.zip
    4 KB · Affichages: 31

Monique

Nous a quitté
Repose en paix
Bonjour,

Index Equiv partout, (sauf pour le rang)

[file name=ClassementApbV5.zip size=34983]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/ClassementApbV5.zip[/file]
 

Pièces jointes

  • ClassementApbV5.zip
    34.2 KB · Affichages: 58

apb

XLDnaute Occasionnel
:eek:hmy:

Merci pour votre contribution à Tous et à Vous Monique.

Effectivement il ya le prob^ème des ex aequo

Tu a bien fait de me mettre la puce à l'oreille.

Dans la feuille 2 les équipes 1 et 2 sont ex aequo j'ai modifié les références des plages nommées mais dans la feuille 3 j'ai une erreur qui apparait le classement ne se fait pas correctement.

Je pesnse à un problème dans la colonne B de la feuille 3 mais !!!!

Merci pour votre aide

Bonne soirée

APB
:S :S [file name=ClassementApbV6.zip size=36650]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/ClassementApbV6.zip[/file]
 

Pièces jointes

  • ClassementApbV6.zip
    35.8 KB · Affichages: 24

Monique

Nous a quitté
Repose en paix
Re,

Une fois remis ex aequo les ex aequo départagés,
il faut départager les ex aequo en rang !
(on finira bien par s'en sortir)

Le rang en feuille 2 :
=SI(H4='';'';RANG(H4;H$4:H$122;1)+LIGNE()/10000)

Le report des rangs en feuille 3 :
=SI(NB(ClassRg)<=NB(B$2:B2);'';PETITE.VALEUR(ClassRg;ENT(LIGNES(B$4:B4)/4)+1))
(Petite.Valeur(plage; 1ère valeur, puis 2ème etc)
L'argument 1, 2 et la suite est remplacé par Ent(Lignes()/4)+1
[file name=ClassementApbV7.zip size=36680]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/ClassementApbV7.zip[/file]
 

Pièces jointes

  • ClassementApbV7.zip
    35.8 KB · Affichages: 61

apb

XLDnaute Occasionnel
:unsure:

D'abord je vous remercie pour votre aide.

Dans la solution de mon problème, j'ai en faissant des tests detecté malheureusement un BUG.

Dans la feuille 1 Quand plusieurs Cavaliers ont le meme nom c'est toujours le Premier trouvé qui est pris pour etre inseré dans le tableau
de cette feuille!!!

Merci de m'aider à touver cette erreur j'ai bien essayé mais je manque de logique je crois.

Bonne soirée

:S :S

APB [file name=ClassementApbV8.zip size=37399]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/ClassementApbV8.zip[/file]
 

Pièces jointes

  • ClassementApbV8.zip
    36.5 KB · Affichages: 42

Discussions similaires

Statistiques des forums

Discussions
313 243
Messages
2 096 509
Membres
106 644
dernier inscrit
7frd5