Somme dans une matrice

29lbl

XLDnaute Nouveau
Bonsoir,


Je cale sur un problème qui me parait tout bête mais que je n'arrive pas à résoudre
Je ne peux pas modifier la structure du tableau ci dessous, celui ci comporte plusieurs colonnes avec les mêmes noms et plusieurs colonne Qté

Question: comment faire la somme de chaque couleur?

Nom Qté Nom Qté
Bleu 3 vert 1
rouge 2 Bleu 2
vert 5 MARRON 3
MARRON 7 rouge 7

réponse attendue: bleu=5 rouge=9 vert=6 marron=10




Merci pour votre aide
 

Fred0o

XLDnaute Barbatruc
Re : Somme dans une matrice

Bonsoir 29lbl,

Si tu mets ton tableau titres compris en A1:D5 et la liste des couleurs en A8:A1, voici la formule à mettre en B8 et à tirer vers le bas :
Code:
=SOMME.SI($A$2:$A$5;A8;$B$2:$B$5)+SOMME.SI($C$2:$C$5;A8;$D$2:$D$5)

A+
 

Calvus

XLDnaute Barbatruc
Re : Somme dans une matrice

Bonsoir,

Si tu avais mis comme c'est demandé dans la charte un fichier exemple, ça éviterait aux autres de le faire pour toi !

Solution dans le fichier joint.

Cordialement


EDIT : Bing Fred0o ! Bonsoir
 

Pièces jointes

  • Classeur2.xlsx
    11.4 KB · Affichages: 40
  • Classeur2.xlsx
    11.4 KB · Affichages: 46
  • Classeur2.xlsx
    11.4 KB · Affichages: 41

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 827
Messages
2 092 557
Membres
105 451
dernier inscrit
mariane_lp