XL 2016 Somme au Format Ans, Moi, Jours

Phoenix23

XLDnaute Occasionnel
Bonjour à toutes et tous.
Dans le fichier ci-joint je souhaiterai comme énoncé dans l'intitulé la somme de 2 dates aux Formats, Ans, Mois, Jours et obtenir le résultat sous le même format.
Si toutefois cela est possible.
D'avance Merci
Cordialement.
 

Pièces jointes

  • 1.xlsx
    11.6 KB · Affichages: 17

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Phoenix, Job, Dranreb,
Une approche simple :
VB:
=SIERREUR(DATEDIF(1;C2-B2+C3-B3;"y")&SI(DATEDIF(1;C2-B2+C3-B3;"y")>1;" ans, ";" an, ")&DATEDIF(1;C2-B2+C3-B3;"ym")&" mois, "&DATEDIF(1;C2-B2+C3-B3;"md")&SI(DATEDIF(1;C2-B2+C3-B3;"md")>1;" jours";" jour");"")
mais évidemment c'est mathématiquement faux puisque les mois seront de 30 jours, et les années de 365 jours. Donc l'erreur pourra être de quelques jours. Tout dépend du besoin, cela peut être suffisant.
 

Pièces jointes

  • 1 (2).xlsx
    10.9 KB · Affichages: 4

Discussions similaires

Réponses
4
Affichages
267

Statistiques des forums

Discussions
312 836
Messages
2 092 623
Membres
105 469
dernier inscrit
gautronmi