simplification de méthodes de calcul

riegel

XLDnaute Nouveau
Bonsoir à tous,

J'utilise un tableau dans le lequel je rentre des données, l'objectif étant au final d'obtenir un prix.
Pour l'exemple, de A1:A100 je renseigne un département, de B1:B100 je mets du texte, de C1;C100 je rentre un format (L1, L2 par exemple).
Ensuite, de A101:A200 j'ai la formule recopiée suivante :
en A101 :SI(A1="ANNUAIRE";CONCATENER(B1;A1;C1);CONCATENER(A1;C1))
en A102 :SI(A2="ANNUAIRE";CONCATENER(B2;A2;C2);CONCATENER(A2;C2))
etc.

Ensuite en D1:D100, j'utilise recherchev(A101;autre classeur;2;FAUX). J'obtiens alors le prix du format en fonction du département.

Existe-t-il un moyen d'éviter de recopier 100 fois la même formule à partir de A101:A200? Mon soucis étant que je me retrouve avec un classeur qui pèse 6 000 Ko car j'ai des milliers de formules.

D'avance je vous remercie pour vos réponses et votre aide.

Riegel
 

Monique

Nous a quitté
Repose en paix
Re : simplification de méthodes de calcul

Bonjour,

Je n’ai pas compris ce que venait faire « Annuaire » dans la colonne des départements.
Ce n’est peut-être pas important pour la suite.

Si l'autre classeur contient la même chose que les cellules A101:A200,
on peut se passer des lignes 101:200
et mettre la « concaténation » dans la formule.
Un essai avec SommeProd

=SOMMEPROD((A$20:A$28=B3&A3&C3)+(A$20:A$28=A3&C3);B$20:B$28)

A$20:A$28 et B$20:B$28, c’est dans l’autre classeur
 

Pièces jointes

  • SommeProdRiegel.zip
    2.9 KB · Affichages: 33

riegel

XLDnaute Nouveau
Re : simplification de méthodes de calcul

Bonsoir Monique,

Merci beaucoup pour ta réponse. En fait, j'ai fait une erreur dans mon exemple. La formule est en fait :
en A101 :SI(B1="ANNUAIRE";CONCATENER(B1;A1;C1);CONCATENER( A1;C1))
en A102 :SI(B2="ANNUAIRE";CONCATENER(B2;A2;C2);CONCATENER( A2;C2))

En effet, si le texte est ANNUAIRE alors le concatenage n'est pas le même.

Etant donné mon erreur, la solution est-elle toujours aussi simple ? J'avoue que j'ai un peu de mal à maitriser la fonction sommeprod.

D'avance je te remercie.

Riegel
 

Discussions similaires

Réponses
7
Affichages
394

Statistiques des forums

Discussions
312 113
Messages
2 085 422
Membres
102 886
dernier inscrit
eurlece