XL 2019 =SI($N$4;LIEN_HYPERTEXTE("#"&ADRESSE(EQUIV($N$4;$B:$B;0);2);"Aller à");"") ne marche pas pour texte

DédéW83

XLDnaute Junior
Bonjour à tous,
J'ai un petit soucis et je rame, je rame....
Voilà, la formule en P4 =SI($N$4;LIEN_HYPERTEXTE("#"&ADRESSE(EQUIV($N$4;$B:$B;0);2);"Aller à");"") marche très bien, mais pas pour le texte..
Auriez vous une solution sans VBA ?
En N4 on entre les 3 premières lettres et on clic sur P4 pour atteindre la ligne recherchée.
 

Hasco

XLDnaute Barbatruc
Repose en paix
Bonjour et bienvenue sur le forum,

Sans doute qu'un fichier exemple (anonymisé et sans données confidentielles) présentant les tenants et aboutissants de votre problème, nous aiderait à vous aider efficacement, même si l'on voit où vous voulez en venir.

Cordialement
 

Hasco

XLDnaute Barbatruc
Repose en paix
Bonjour,

Voici.

Votre test Si(N$4 ; ; )ne fonctionnait pas pour du texte
Si(N$4<>"" ; ; )
puis pour equiv : Equiv(N$4& "*";$B:$B;0)

cordialement
 

Pièces jointes

  • Gestion de Stock -TEST.xlsx
    29.8 KB · Affichages: 4

DédéW83

XLDnaute Junior
Bonjour David et à tous,
je vous remercie pour votre aide qui m'a permis de trouver exactement ce que je voulais.
Je vous souhaite à tous bonne continuation et surtout restez prudent, le diable rode....
Je mets le post en résolu.
Cordialement,
Dédé.
 

Discussions similaires

Statistiques des forums

Discussions
313 276
Messages
2 096 760
Membres
106 743
dernier inscrit
sshkm16