si(et(ou???

Evelynetfrancois

XLDnaute Impliqué
bonjour a toutes et tous !!

je cherche une formule toute simple certainement mais je trouve pas !!
je m embrouille ............

si CA < 1000= rien
si CA > 1000 mais < 1999= 5%
si CA > 2000 mais < 2999=20%
si CA > 3000 mais < 3999= 30%
si CA > 4000 alors = 50%

pouvez vous me montrer un exemple...
apres j adapterais facilement grace a vous !!!

tres bonne journée a tous et merci d avance

E et F
 
C

Compte Supprimé 979

Guest
Re : si(et(ou???

Salut EvelyneEtFrancois,

si CA < 1000= rien
si CA > 1000 mais < 1999= 5%
si CA > 2000 mais < 2999=20%
si CA > 3000 mais < 3999= 30%
si CA > 4000 alors = 50%
ATTENTION incohérence dans tes critères

La formule qui devrait aller
Code:
=Si(CA<1000;0;SI(ET(CA>=1000;CA<2000);5%;SI(ET(CA>=2000;CA<3000);20%
;SI(ET(CA>=3000;CA<4000);30%;50%))))

Il suffit que tu nommes la cellule qui contient ton Chiffre d'Affaire, en "CA" et le tour est joué ;)

A+

Edit : Oups, salut Tibo, pas mal ta formulation, bien vue
 

Evelynetfrancois

XLDnaute Impliqué
Re : si(et(ou???

re tibo et BrunoM45

=SI(A10<1000;A10*0;SI(ET(A10>=1000;A10<2000);A10*5%;SI(ET(A10>=2000;A10<3000);A10*20%;SI(ET(A10>=3000;A10<4000);A10*30%;A10*50%))))
J'ai juste modifier un peu la formule pour obtenir le resultat directement dans la cellule ou se trouve la formule


merci beaucoup à vous deux , je tournais désespérement autour sans jamais trouver qq chose de juste !!!!

bonne journée à vous
et encore un trés grand MERCI pour votre justesse et votre rapidité

E et F
 

Dugenou

XLDnaute Barbatruc
Re : si(et(ou???

Salut à tous

Juste un mot sur le principe : si un des % ou une borne doit changer il faut modifier la formule : cela peut être fastidieux. Pour ma part j'aurais fait avec un recherchev avec vrai en dernier critère. Cela permet d'utiliser une table bornes <=> % et il n'y a que la table à modifier.

D'autre part en conservant l'écriture avec des SI : on doit pouvoir éviter les ET en écrivant la formule à l'envers :
=A10*SI(A10<4000;SI(A10<3000;SI(A10<2000;SI(A10<1000;0;0,05);0,2);0,3);0,5)

Cordialement
 
C

Compte Supprimé 979

Guest
Re : si(et(ou???

Salut "Ch'tite Biloute" :D

Juste un mot sur le principe : si un des % ou une borne doit changer il faut modifier la formule : cela peut être fastidieux. Pour ma part j'aurais fait avec un recherchev avec vrai en dernier critère. Cela permet d'utiliser une table bornes <=> % et il n'y a que la table à modifier.
Judicieux effectivement, mais cela oblige a mettre une table quelque part sur la feuille, ce qui n'est pas toujour pratique ;)

D'autre part en conservant l'écriture avec des SI : on doit pouvoir éviter les ET en écrivant la formule à l'envers :
=A10*SI(A10<4000;SI(A10<3000;SI(A10<2000;SI(A10<10 00;0;0,05);0,2);0,3);0,5)
Personnellement, je trouve la formulation de cette manière, illisible !
Donc un peu de "SI(ET(" ne fait pas de mal.

A+
 

Discussions similaires

Réponses
2
Affichages
571
Réponses
3
Affichages
352
Réponses
7
Affichages
852

Statistiques des forums

Discussions
312 854
Messages
2 092 830
Membres
105 540
dernier inscrit
missmel59