selection de cellules avec condition

drisou

XLDnaute Occasionnel
bonjour le forum, encore besoin d'aide ,vivement le jour ou je serais en mesure de d' en donner , il faut que j apprenne beaucoup pour ca. j ai un tableau et par lignes j ai 8 cellules soit 8 colonnes, ces cellules doivent contenir des nombres par exemple : a1 a h1 (a1 contient le chiffre 1;b1 le chiffre 2 ,c1 le chiffre 3, d1 le chiffre 5, e1 le chiffre 4,f1 le chiffre 10,g1 la chiffre 15,h1 la chiffre 20...)
en realité il y a 35 nombres differents

les chiffres 1, 5 appartiennent a une categorie que je nomme 'depot'
les chiffres 2,15,10 appartient a la categorie 'pm'
les chiffres 3 et 4,20 appartient a la categorie'soir'

ma question est comment calculer dans cette plage a1:h1 le nombre de chiffre corespondant a la categorie 'depot
ensuite a la categorie 'pm
et categorie 'soir'.

j espere voir été clair. merci pour votre attention et votre aide.
 

Gael

XLDnaute Barbatruc
Bonjour Drisou,

Essaye avec la formule suivante:

{=SOMME(NB.SI(A1:H1;{2.15.10}))}

Les accolades en début et fin sont générées automatiquement en saisissant la formule sous forme matricielle (Ctrl Maj Retour) mais les accolades internes {2.15.10} sont saisies manuellement à l'intérieur de la formule (Matrice de constantes) et les chiffres sont séparés par des '.'.

Tu peux si tu préfères mettre les chiffres dans des cellules et indiquer la plage de cellules dans la formule:

{=SOMME(NB.SI(A1:H1;C15:E15))}

@+

Gael
 

Discussions similaires

Statistiques des forums

Discussions
312 923
Messages
2 093 663
Membres
105 780
dernier inscrit
Autric