[Résolu] Recherche liste de valeur dans le contenu d'une cellule

Alex57

XLDnaute Nouveau
Bonjour à tous et très bonne année 2013.

J'ai mis un fichier exemple en pièce jointe.
Je souhaite compléter la colonne D (en vert) avec PM ou PP
PM si on trouve dans la colonne C (ex. : Dupont SARL et compagnie) un élément de la colonne A (ex. : SARL). Mais
PP sinon.
C'est faisable en enchainant les IF avec des SEARCH, mais il peut y avoir beaucoup de valeur dans la colonne A donc ce n'est pas très propre.

Je vous remercie d'avance pour votre aide.

Alex
 

Pièces jointes

  • Exemple.xlsx
    9.9 KB · Affichages: 42
  • Exemple.xlsx
    9.9 KB · Affichages: 48
  • Exemple.xlsx
    9.9 KB · Affichages: 47
Dernière édition:

JHA

XLDnaute Barbatruc
Re : Recherche liste de valeur dans le contenu d'une cellule

Bonjour à tous,

Peut être en matricielle avec plage nommée
Code:
=SI(OU(ESTNUM(CHERCHE(texte;C2;1));ESTNUM(CHERCHE(SUBSTITUE(".";"";texte);C2;1)))=VRAI;"PM";"PP")

JHA
 

Pièces jointes

  • Exemple (7).xlsx
    10.3 KB · Affichages: 40
  • Exemple (7).xlsx
    10.3 KB · Affichages: 40

Discussions similaires

Statistiques des forums

Discussions
312 920
Messages
2 093 640
Membres
105 769
dernier inscrit
AVAST