Autres (RESOLU)Format d'une cellule (vba)

chaelie2015

XLDnaute Accro
Bonjour Forum
je souhaite afficher dans les cellules de la colonne (par exemple D) format d'un nombre "000/BEL/année de la cellule de colonne B"
exemple : j'ai une colonne B (date) et colonne D ( nombre)
si je saisi dans une cellule de D un nombre ( par exemple dans D6=9) il s'affiche automatiquement 009/BEL/2022
l'année 2022 c'est l'année dans la cellule B6=12/01/2022.
si B14= 12/11/2020 alors quand je sais une valeur dans la cellule D14 un chiffre par exemple 25 alos j'aurai automatiquement dans la cellule D14 = 025/BEL/2020.
et ainsi de suite ...

Merci par avance
 
Dernière édition:

Jacky67

XLDnaute Barbatruc
Bonjour Forum
je souhaite afficher dans les cellules de la colonne (par exemple D) format d'un nombre "000/BEL/année de la cellule de colonne B"
exemple : j'ai une colonne B (date) et colonne D ( nombre)
si je saisi dans une cellule de D un nombre ( par exemple dans D6=9) il s'affiche automatiquement 009/BEL/2022
l'année 2022 c'est l'année dans la cellule B6=12/01/2022.
Merci par avance
Bonjour,
Essaye comme ceci
Le tout pour la ligne 6
Code:
=TEXTE(D6;"000")&"/BEL/"&ANNEE(B6)

en vba, résultat en A6
VB:
   [a6] = Format([d6], "000") & "/BEL/" & Year([b6])
 
Dernière édition:

Phil69970

XLDnaute Barbatruc
Bonjour à tous

Je te propose :
Non testé faute de fichier exemple..:oops:

VB:
Sub Mon_Format()
Application.ScreenUpdating = False
Dim Derlig&
Derlig = Worksheets("Feuil1").Range("B" & Rows.Count).End(xlUp).Row

For i = 2 To Derlig
    Range("D" & i).Value = Format(Range("D" & i).Value, "000") & "/BEL/" & Year(Range("B" & i).Value)
Next i
End Sub

Edit code modifié vu le fichier fourni......

*Merci de ton retour

@Phil69970
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
299 847
Messages
1 979 560
Membres
206 772
dernier inscrit
Checopa