rechercher puis retourner numéro de ligne

samuel3995

XLDnaute Nouveau
Bonjour tout le monde,

j'ai un soucis pour trouver une fonction sur excel.

déjà je sais comment retourner une valeur rechercher et aussi retourner une valeur dans la même ligne ou la même colonne d'une valeur rechercher (à l'aider de recherchev et rechercheh).

Mon but est de retourner un ensemble de données qui ont le même attribut
ie:
colonne A : a b v a c e a
colonne B : 2 4 6 8 4 6 9

je veux que ma fonction recherche les "a" et me retourne dans une autre feuille "2","8","9"; (le problème c'est que je n'arrive à retourner que la premier valeur trouve cad : 2).

voila j'espère que j'étais assez clair

merci pour votre aide
 

Tibo

XLDnaute Barbatruc
Re : rechercher puis retourner numéro de ligne

Bonjour,

Une tentative avec une formule matricielle :

Code:
=SI(LIGNES($1:1)>NB.SI($A$1:$A$7;$D$1);"";INDEX($B$1:$B$7;PETITE.VALEUR(SI((
$A$1:$A$7=$D$1);($A$1:$A$7=$D$1)*LIGNE($A$1:$A$7));LIGNES($1:1))))
Formule matricielle à valider par CTRL + MAJ + ENTREE

D1 contient la lettre (a dans ton exemple)

Formule à recopier vers le bas

Plage de cellules à adapter.

@+
 

Discussions similaires

Réponses
5
Affichages
297

Statistiques des forums

Discussions
312 836
Messages
2 092 623
Membres
105 469
dernier inscrit
gautronmi