Recherche ?????

fourezizou

XLDnaute Occasionnel
bonjoure la forum
je recherche un formule au nu vba pour faire la recherche de la colonne D dans le tableau principale malgré les caractères de nom de colonne D est différente par a pour les caractères des noms de tableau principale colonne A.
 

Pièces jointes

  • recherche.xlsx
    10.1 KB · Affichages: 70
  • recherche.xlsx
    10.1 KB · Affichages: 87
  • recherche.xlsx
    10.1 KB · Affichages: 88

job75

XLDnaute Barbatruc
Re : Recherche ?????

Bonjour fourezizou,

Pour obtenir les codes, formule en E1 à tirer vers le bas :

Code:
=RECHERCHEV("*"&SUBSTITUE(SUBSTITUE(SUBSTITUE(D1;" ";"*");"A";"?");"E";"?")&"*";A$2:B$9;2;0)
Pas compris ce que vous voulez faire avec la cellule E10 "recherche".

Fichier joint.

A+
 

Pièces jointes

  • recherche(1).xls
    28.5 KB · Affichages: 60
  • recherche(1).xls
    28.5 KB · Affichages: 80
  • recherche(1).xls
    28.5 KB · Affichages: 79

fourezizou

XLDnaute Occasionnel
Re : Recherche ?????

RE la forum job75
J'ai essayé d'appliquer le formule a mon travaille mais le problème c'est que je le tableau principale existe dans classeur tableau principale et le tableau que j'écris est en autre classeur.
Pouvez-vous aider plus J'ai essayé et je ne pouvais pas
 

Pièces jointes

  • recherche3.xlsx
    8.3 KB · Affichages: 57
  • le tableau principale.xlsx
    8.7 KB · Affichages: 26

job75

XLDnaute Barbatruc
Re : Recherche ?????

Re,

Vous n'avez pas beaucoup cherché pour adapter la formule :rolleyes:

Les 2 fichiers doivent être ouverts.

Entrez en E2 du fichier recherche3.xlsx :

Code:
=RECHERCHEV("*"&SUBSTITUE(SUBSTITUE(SUBSTITUE(A2;" ";"*");"A";"?");"E";"?")&"*";'[le tableau principale.xlsx]Feuil1'!$A$2:$B$9;2;0)
A+
 

Discussions similaires

Statistiques des forums

Discussions
312 895
Messages
2 093 384
Membres
105 715
dernier inscrit
Yoenai