Microsoft 365 Recherche V

Virginie31p

XLDnaute Nouveau
Bonjour,
Je voudrais dans mon onglet "planning patient" - lorsque je sélectionne mon patient toutes les autres cases se renseigne en fonction de ce que j'ai rentré dans mon onglet "fichier patient".
Ma formule recherche V ressort en erreur et je ne vois pas ou est l'erreur. (j'ai essayé de me servir d'un tuto)
De plus, j'ai fusionné dans mon fichier patient le nom et prénom et donc dans le déroulé cela fait des espaces, peut on les enlever ?
Merci pour votre aide !
Bonne journée.
 

Pièces jointes

  • Plannification HDJ3.xlsx
    67.6 KB · Affichages: 9

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Nini,
Un essai en PJ avec une approche Index Equiv du genre :
VB:
=SI(INDEX('Fichier patient'!7:7;EQUIV($C$12;'Fichier patient'!$3:$3;0))<>"";INDEX('Fichier patient'!7:7;EQUIV($C$12;'Fichier patient'!$3:$3;0));"")
donc dans le déroulé cela fait des espaces
Pas compris ce point, soyez plus clair.
 

Pièces jointes

  • Plannification HDJ3.xlsx
    72.9 KB · Affichages: 7

Virginie31p

XLDnaute Nouveau
Bonjour Nini,
Un essai en PJ avec une approche Index Equiv du genre :
VB:
=SI(INDEX('Fichier patient'!7:7;EQUIV($C$12;'Fichier patient'!$3:$3;0))<>"";INDEX('Fichier patient'!7:7;EQUIV($C$12;'Fichier patient'!$3:$3;0));"")

Pas compris ce point, soyez plus clair.
Ah merci !

Quand je selectionne mon patient il y a mon patient "ab" puis un espace puis le suivant (étant donné que mes cellule sont fusionnées.
Est il possible de supprimer la ligne blanche ou bien je dois défusionner mes cellules ?
1712652815099.png
 

fanch55

XLDnaute Barbatruc
Salut,
Dans le même genre que @riton00 et comme vous dites utiliser M365,
Dans la feuille "Paramétrage" en cellule M1 ( par exemple ) :
Code:
=TRANSPOSE(FILTRE('Fichier patient'!B3:K3;'Fichier patient'!B3:K3<>""))
Puis en validation Liste de la cellule C12 dans "Planning patient" :
Code:
=Paramétrage!M1#

Nota: le classeur ne pourra être exploité qu'à partir d'office 2021, la proposition de @riton00 fonctionnant sur les versions antérieures également .
 

Virginie31p

XLDnaute Nouveau
Salut,
Dans le même genre que @riton00 et comme vous dites utiliser M365,
Dans la feuille "Paramétrage" en cellule M1 ( par exemple ) :
Code:
=TRANSPOSE(FILTRE('Fichier patient'!B3:K3;'Fichier patient'!B3:K3<>""))
Puis en validation Liste de la cellule C12 dans "Planning patient" :
Code:
=Paramétrage!M1#

Nota: le classeur ne pourra être exploité qu'à partir d'office 2021, la proposition de @riton00 fonctionnant sur les versions antérieures également .
Merci à vous !

Je me suis servies de votre formule.
 

Discussions similaires

Réponses
6
Affichages
187
Réponses
1
Affichages
333

Statistiques des forums

Discussions
313 315
Messages
2 097 067
Membres
106 825
dernier inscrit
benoit49