XL 2010 Recherche info + doublon dans colonne

Stephxi

XLDnaute Nouveau
Bonjour,
Je sèche sur une recherche Excel.
En bref, en m'appuyant sur le suffixe (4 derniers caractères), je cherche à savoir si il y a une autre occurrence identique précédé de TROC ou TRUC existe dans la colonne "Noms".

Pour être plus explicite :
- Recherche les 4 derniers caractères de chacune des lignes de la colonne "Noms"
- Recherche si ces 4 caractères sont présents plusieurs fois dans la colonne "Nom"
- Si plusieurs occurrences = vrai
- Si simple occurrence = faux

Si vous avez des idées !!!???
Bien à vous !

Stéphane
NomEtat
HELLOHELLO-POUET-TRUC-34552 occurrences (Vrai)
HELLOHELLO-POUET-TROC-34552 occurrences (Vrai)
HELLOHELLO-POUET-TRUC-44452 occurrences (Vrai)
HELLOHELLO-POUET-TROC-44452 occurrences (Vrai)
HELLOHELLO-POUET-TRUC-46181 occurrences (Faux)
 

Stephxi

XLDnaute Nouveau
Excellent ! Vraiment excellent, merci !
Je vais partir sur la condition vrai/faux car je dois multiplier un taux en fonction du résultat obtenu, en bref :
- Si Vrai et TROC = 25%
- Si Vrai et TRUC = 75 %
- Si Faux : = 100 %
Avez vous une astuce pour éviter de créer un nouveau test de TROC ou TRUC ?
Merci à vous !!
stéphane
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer
VB:
=SI(ET(NB.SI(A:A;"*"&DROITE(A2;4))>1;ESTNUM(CHERCHE("*"&"Truc"&"*";A2)));75%;SI(ET(NB.SI(A:A;"*"&DROITE(A2;4))>1;ESTNUM(CHERCHE("*"&"Troc"&"*";A2)));25%;"-"))

JHA
 

Pièces jointes

  • Stephxi.xlsx
    10.2 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
299 728
Messages
1 978 789
Membres
206 395
dernier inscrit
Bilina