XL 2013 recherche en fonction de la valeur et du rang sur une ligne

komarlehomard

XLDnaute Junior
Bonjour à toutes et tous,

Un fois de plus je viens solliciter vos connaissances, j’ai 1 fichier joint j’aimerais que dans la cellule diag1 (V6) il y ai la première valeur TOR (ligne A6:T6) si le code équivalent au TOR est 1 et ainsi de suite et rien si il y a plus diag.

En espérant avoir été clair. 😊

Je vous remercie par avance du temps que vous allez m’accorder, bonne journée à tous.
 

Pièces jointes

  • aide.xlsm
    12.1 KB · Affichages: 3
Solution
Bonjour à tous,

J'ai remis la formule avec les bons paramètres pour donner les résultats escomptés.
VB:
=SIERREUR(DECALER($Q6;;PETITE.VALEUR(SI($R6:$AK6=1;COLONNE($R6:$AK6)-18);COLONNE(A$1)));"")
Par contre, concernant le code VBA, je ne peux pas t'aider et je laisse faire les spécialistes.

JHA

komarlehomard

XLDnaute Junior
Bonjour à tous,

A essayer
VB:
=SIERREUR(DECALER($A6;;PETITE.VALEUR(SI($B6:$U6=1;COLONNE($B6:$U6));COLONNE(A$1)));"")

JHA
Re bonjour à tous
Désolé je me suis enflammé, je n'arrive pas à adapter la formule, en plus je me suis rendu compte que c'est une matricielle et je dois insérer dans une macro est ce que cela pose un problème ?
est ce qu'il y aurait une solution non matricielle ?
je joins le fichier dans la configuration de classeur de base, je suis preneur d'explications aussi.
Merci beaucoup du temps que vous allez m'accorder.
 

Pièces jointes

  • aide.xlsm
    13.4 KB · Affichages: 1

JHA

XLDnaute Barbatruc
Bonjour à tous,

J'ai remis la formule avec les bons paramètres pour donner les résultats escomptés.
VB:
=SIERREUR(DECALER($Q6;;PETITE.VALEUR(SI($R6:$AK6=1;COLONNE($R6:$AK6)-18);COLONNE(A$1)));"")
Par contre, concernant le code VBA, je ne peux pas t'aider et je laisse faire les spécialistes.

JHA
 

Pièces jointes

  • aide (2).xlsm
    13.5 KB · Affichages: 1

komarlehomard

XLDnaute Junior
Bonjour à tous,

J'ai remis la formule avec les bons paramètres pour donner les résultats escomptés.
VB:
=SIERREUR(DECALER($Q6;;PETITE.VALEUR(SI($R6:$AK6=1;COLONNE($R6:$AK6)-18);COLONNE(A$1)));"")
Par contre, concernant le code VBA, je ne peux pas t'aider et je laisse faire les spécialistes.

JHA
Trop sympa de t'etre penché sur mon cas.
Ce coup ci j'ai réussi à l'adapter.
Merci beaucoup du temps que tu as passé pour m'aider, bonne journée.
 

Discussions similaires

Statistiques des forums

Discussions
313 283
Messages
2 096 810
Membres
106 751
dernier inscrit
Souleymani