XL 2013 Recherche de Valeurs Approximatives dans un Tableau Excel

toto142

XLDnaute Nouveau
Bonjour,

Je souhaite obtenir de l'aide pour rechercher automatiquement une valeur approximative dans un tableau Excel.

Voici le contexte : je cherche une solution pour trouver une valeur approximative dans une série de données. J'ai tenté d'utiliser la formule =RECHERCHEV, mais cela n'a pas fonctionné dans les cellules X23:Y25

Dans mon fichier Excel, j'ai essayé de créer un tableau, mais sans succès. J'ai également ajouté manuellement les valeurs que je cherchais juste en dessous du tableau, mais cette méthode n'est pas pratique.

Auriez-vous une solution ou une méthode efficace pour rechercher ces valeurs approximatives de manière automatique dans Excel ? Merci par avance pour votre aide.
 

Pièces jointes

  • Gauss.xlsx
    49.8 KB · Affichages: 9
Solution
Bonjour Toto,
Peut être avec en X23 :
VB:
=INDEX($AK$4:$AK$43;EQUIV(X16;$AB$4:$AB$43;-1))
Mais il donnera pour 3 sigma 162 au lieu de 292 car il prend la première valeur la plus proche dont l'écart est positif, mais ça reste une "valeur approximative"

job75

XLDnaute Barbatruc
Bonsoir toto142, sylvanu,

On ne sait pas trop ce qu'il faut chercher mais voyez le fichier joint.

Valeur cherchée en E4 :
Code:
=ARRONDI(MIN(C$2:C$403);3)+(LIGNE()-4)/1000
N° le plus proche en F4 (formule matricielle) :
Code:
=EQUIV(MIN(ABS(C$4:C$403-E4));ABS(C$4:C$403-E4);0)
A+
 

Pièces jointes

  • Plus proche.xlsx
    27.5 KB · Affichages: 3

Statistiques des forums

Discussions
313 322
Messages
2 097 141
Membres
106 850
dernier inscrit
benbeckman