Recherche de texte basée sur une liste

punawa

XLDnaute Nouveau
Bonjour à tous.


Je me suis un peu cassé la tête vendredi au boulot pour accélérer mon travail, mais je n'ai point réussi.

J'ai donc des centaines de cellules contenant des textes différents.
A côté de cela, j'ai une liste d'environ 80 noms.
Il faudrait qu'une fonction de recherche vérifie si au moins un seul de ces noms figurent dans la cellule et si c'est le cas, qu'il me note 'OK' dans la cellule à coté de la ligne. Dans le cas contraire 'NOT OK'.


Il faut donc qu'Excel vérifie les 80 possibilités. (et faut-il que mettre ces 80 noms dans une cellule chacun ?)

J'espère que c'est clair. Ca ne semble pas compliqué, mais je cale :eek:

Merci pour votre aide.
 

Cousinhub

XLDnaute Barbatruc
Re : Recherche de texte basée sur une liste

Bonsoir,
et bienvenue sur XLD
regarde le fichier joint, et l'utilisation de la formule NB.SI

Si ce n'est pas cela, essaie de joindre un fichier joint, exempt de données confidentielles, et surtout "zippé" (jp veille au grain....:D)
 

Pièces jointes

  • punawa.zip
    4.2 KB · Affichages: 21

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : Recherche de texte basée sur une liste

Bonsoir,


MFC/La formule est
=SOMMEPROD(ESTNUM(TROUVE(Liste;A1))*1)>0

Avec formule:

=SI(SOMMEPROD(ESTNUM(TROUVE(Liste;A1))*1)>0;"ok";"")

JB
 

Pièces jointes

  • Classeur1.xls
    26 KB · Affichages: 48
  • Classeur1.xls
    26 KB · Affichages: 48
  • Classeur1.xls
    26 KB · Affichages: 51
Dernière édition:

punawa

XLDnaute Nouveau
Re : Recherche de texte basée sur une liste

Autre petite question (je viens d'y penser :rolleyes:)
Est-il possible que la cellule où se trouvera la réponse à la recherche (ok/not ok) se mette automatiquement en couleur de fond rouge quand c'est 'ok' (ou le 'ok' en rouge & gras) ?
 

jeanpierre

Nous a quitté
Repose en paix
Re : Recherche de texte basée sur une liste

Bonsoir à tous,

Oui, c'est possible avec la Mise en Forme conditionnelle dans Format, exemple : =$a1="ok", le motif de ton choix... ou la couleur de police....

3 Conditions sous excel 2003 et antérieur, cela laisse de la marge un peu

Te lire sur le sujet.

Jean-Pierre
 

Discussions similaires

Statistiques des forums

Discussions
312 017
Messages
2 084 640
Membres
102 626
dernier inscrit
Abdoulaziz_17