Recherche comment faire une formule ( surement avec recherche vertical avec si )

Coube

XLDnaute Nouveau
Bonjour

Après plusieurs recherche, j'ai toujours pas réussit a trouver comment faire ma formule.

Dans mon fichier j'ai une liste de profilé avec des prix standard et non standard ( les liste sont sujet a changer souvent dépendant du marché)

J'aimerais que dans ma cellule b2 avoir une valeur de la liste d'exception s'il trouve pas le nom du profilé il prend une valeur du tableau standard.

je sait pas si c'est possible de faire?
 

Pièces jointes

  • DOSSIER TEST 1.xls
    15.5 KB · Affichages: 106
  • DOSSIER TEST 1.xls
    15.5 KB · Affichages: 116
  • DOSSIER TEST 1.xls
    15.5 KB · Affichages: 117

Coube

XLDnaute Nouveau
Re : Recherche comment faire une formule ( surement avec recherche vertical avec si )

la cellule B2 fonctionne avec le nom de la cellule A3 (w4X13)
Donc la valeur du tableau d exception serait I4

si on prend comme exemple B4 qui fonctionne avec A4 (w5X16)
mais ce profile se retrouve pas dans les exception il dois prendre la valeur de F3

je dois toujours faire une recherche dans les exception avant de conner la valeur du tableau standard .
 

Victor21

XLDnaute Barbatruc
Re : Recherche comment faire une formule ( surement avec recherche vertical avec si )

Re,

Persuadé que ce n'est pas ça, mais à tout hasard :
=SIERREUR(DECALER($H$3;EQUIV(A3;$H$4:$H$6;0);1;1);$F$3)
Si votre liste standard ne contenait qu'une lettre (ou au moins un nombre constant de lettres) en début de référence :
=SIERREUR(DECALER($H$3;EQUIV(A3;$H$4:$H$6;0);1;1);DECALER($E$2;EQUIV(GAUCHE(A3;1);$E$3:$E$14;0);1;1))
Mais ce n'est pas le cas, et je ne puis vous apporter d'aide avec la présentation telle que vous l'indiquez
 

Coube

XLDnaute Nouveau
Re : Recherche comment faire une formule ( surement avec recherche vertical avec si )

J'ai réussit a faire cela

mais quand la valeur du SI est faux ca fonctionne plus
 

Pièces jointes

  • DOSSIER TEST 1.xls
    16.5 KB · Affichages: 77
  • DOSSIER TEST 1.xls
    16.5 KB · Affichages: 75
  • DOSSIER TEST 1.xls
    16.5 KB · Affichages: 71

R@chid

XLDnaute Barbatruc
Re : Recherche comment faire une formule ( surement avec recherche vertical avec si )

Bonsoir @ tous,
Salut Patrick :eek:,
@ Coube,
tu n'as pas essayé la première formule de Patrick,
Persuadé que ce n'est pas ça, mais à tout hasard : =SIERREUR(DECALER($H$3;EQUIV(A3;$H$4:$H$6;0);1;1);$F$3)
si tu n'as pas Excel2007, alors tu peux faire en B3 avec,
Code:
=SI(NB.SI(H:H;A3);RECHERCHEV(A3;H:I;2;0);F$3)
@ tirer vers le bas
@ micalement
 

Coube

XLDnaute Nouveau
Re : Recherche comment faire une formule ( surement avec recherche vertical avec si )

Je suis en train D'assayer

c'est des formules que je connais pas.

ca donne comme résultal #nom? pour la formule
=SIERREUR(DECALER($H$3;EQUIV(A3;$H$4:$H$6;0);1;1); $F$3)

j'essait ce que tu propose la

ca fonctionne #1 ta solution
=SI(NB.SI(H:H;A3);RECHERCHEV(A3;H:I;2;0);F$3)

Je vais tenter de comprendre ta formule et un gros merci pour ton aide.
 
Dernière édition:

Victor21

XLDnaute Barbatruc
Re : Recherche comment faire une formule ( surement avec recherche vertical avec si )

Re, bonsoir, R@chid :)

le problème est que si la valeur n'est pas trouvée dans le premier tableau, la valeur renvoyée sera systématiquement celle contenue dans F3...
 

Discussions similaires

Réponses
2
Affichages
122
Réponses
11
Affichages
228

Statistiques des forums

Discussions
312 929
Messages
2 093 715
Membres
105 794
dernier inscrit
mallet