problème windows8 ?

Milmar

XLDnaute Nouveau
bonjour a toutes et tous
alors voila mon problème , je viens de migrer sur windows 8 et depuis un tableau que j'utilisai pour faire une connexion automatique sur un site ne fonctionne plus , en gros la page s'ouvre mais rien ne ce passe..
la formule utilisée est la suivante

Option Explicit
Const logui As String = "mon log"
Const mdp As String = "mon pass"
Const userlog As String = "mon us id 2"


Private Sub CommandButton1_Click()

Dim ie As Object 'InternetExplorer
Dim Helem As Object 'IHTMLElement
Dim MaPageHtml As Object 'HTMLDocument

On Error Resume Next


Set ie = CreateObject("InternetExplorer.Application")
ie.Visible = True
ie.Navigate ("https://e-finance.postfinance.ch/ef/secure/html/onl_kdl_login.proceed?login&noto")

Do Until ie.ReadyState = 4
DoEvents
Loop
Set MaPageHtml = ie.Document

'Numéro d'abonné
Set Helem = MaPageHtml.getElementsByName("etnr").Item
Helem.Value = logui

'mot de passe
Set Helem = MaPageHtml.getElementsByName("password").Item

Helem.Value = mdp

Set Helem = MaPageHtml.getElementsByName("userid").Item

Helem.Value = userlog
Application.Wait (Now + TimeValue("0:00:2"))

Set Helem = MaPageHtml.getElementsByName("e_finance_userid_submit").Item
Helem.Click

End Sub

tout fonctionnai à merveille sous windows 7 et la plus rien ?
des truc à changer dans uac de windows 8 ou autre , je suis perdu .
merci de votre aide , meilleurs salutations.
 
Dernière édition:

Statistiques des forums

Discussions
312 875
Messages
2 093 148
Membres
105 641
dernier inscrit
Naoel