XL 2021 Problème calcul sommeprod

philou914500

XLDnaute Nouveau
Bonjour, Dsl tout d'abord si le sujet a été traité dans un poste mais je ne l'ai pas trouvé.
Mon problème est le suivant : Je vais tenter d'être le plus clair possible.
J'ai un fichier avec deux colonnes :
Colonne A : un numéro de plan avec son indice.
Colonne B : sont status.

Je voudrais juste connaître combien de plan unique sont avec le status "ABS".
J'ai utlisé cette formule =SOMMEPROD((1/NB.SI(Feuil2!$A$2:$A$3520;Feuil2!$A$2:$A$3520)*(Feuil2!$B$2:$B$3520=A2))) "A2" étant la cellule qui contient "ABS"
et je trouve 33 alors que quand je fais une concaténation des deux colonnes puis suppression des doublons je trouve 37 références unique????

Pourquoi mon calcul est faux?

Merci de votre aide et de vos retour.
Je vous joins un fichier pour être plus pratique
Cdlt.
Philippe.
 

Pièces jointes

  • denombrer_abs_avec_plan_unique.xlsx
    106 KB · Affichages: 2
Solution
Bonjour,
Edit : Salut @Cousinhub
Dans ta formule tu indiques 3520
1701703903062.png

alors que tu as 3530 lignes
1701703992697.png

Si tu changes 3520 en 3530 on obtient bien 37.
C'est donc simplement peut être ceci le problème
@+ Lolote83

Cousinhub

XLDnaute Barbatruc
Inactif
Bonjour,
En transformant la plage de la feuil2 en Tableau Structuré (TS), et avec cette formule, compatible xl2021, j'obtiens également 37
Code:
=NBVAL(UNIQUE(FILTRE(T_Data[PN&ind];T_Data[Status]=A2)))
Et en effectuant un essai "Suppression Doublons", j'obtiens également 37...
A voir?
 

Pièces jointes

  • denombrer_abs_avec_plan_unique.xlsx
    108.6 KB · Affichages: 0

philou914500

XLDnaute Nouveau
Bonjour, Je vous remercie de vos réponses et encore dsl, car franchement j'aurais pu trouvé tout seul.
Je pensais que cela venait de la formule, cela venait juste de la personne entre la chaise et la sourie... :)
Je vous souhaite une bonne journée et de bonnes fête de fin d'années. 🎁🎀🎉
 

Discussions similaires

Réponses
16
Affichages
1 K
Réponses
20
Affichages
2 K

Statistiques des forums

Discussions
313 281
Messages
2 096 785
Membres
106 748
dernier inscrit
Abdel93