Problématique décalage de cases

romanosprestos

XLDnaute Nouveau
Bonjour à tous, et merci de votre aide par avance :)

je commence par un screen du problème et j'explique ensuite :

1596445297128.png


J'ai en haut des données, chaque éléve a 5 heures de cours au mois n°1, 4h le mois 2, 2h le mois 3 etc... et les élèves peuvent avoir une rentrée décalée (ils suivront le même patern quoi qu'il arrive). Est ce que c'est possible que le tableau se remplisse et que les mois se décalent simplement avec la valeur "Décalage mois" sans passer par une macro ? Et si oui comment :)

Bonne journée !
 

job75

XLDnaute Barbatruc
Bonjour romanosprestos, Roblochon, mapomme,

Merci pour le fichier mapomme, formule plus simple et non matricielle en C8 :
Code:
=SIERREUR(RECHERCHEH("Mois "&STXT(C$7;6;5)-$B8;$1:$2;2;0);"")
A tirer à droite et vers le bas.

A+
 

Pièces jointes

  • romanosprestos(1).xlsx
    12.8 KB · Affichages: 2

Discussions similaires

Statistiques des forums

Discussions
313 198
Messages
2 096 141
Membres
106 505
dernier inscrit
ngomez