Nbre de cas par classes de prix

Michel_ja

XLDnaute Occasionnel
Bonjour à tous, je bloque sur un fichier excel, auriez-vous une solution ?
J'ai une liste de produits X avec les prix à l'importation correspondants et j'ai une table avec 11 classes de prix, par ordre croissant. J'aimerai savoir combien il y a de produits importés par catégories de prix définis dans cette table. J'ai pensé à la fonction si (plus grand et plus petit que) mais il me semble qu'on ne peut imbriquer que sept Si !!! Aussi, ma liste de produits importés contient des milliers de lignes.
Merci d'avance. J'ai joint un petit fichier.
 

Pièces jointes

  • Classes.xlsx
    9.4 KB · Affichages: 31

Jocelyn

XLDnaute Barbatruc
Re : Nbre de cas par classes de prix

Bonjour le Forum,
Bonjour Michel_ja,

peut être comme ca si j'ai bien compris:

en F5 =SOMMEPROD(($B$2:$B$22<=F4)*1)

en G5 =SOMMEPROD(($B$2:$B$22<=G4)*($B$2:$B$22>F4)) ensuite tu peux étirer la formule de G5 vers la droite autant que de besoin

Voir fichier

Cordialement
 

Pièces jointes

  • Classes.xls
    8.5 KB · Affichages: 27
  • Classes.xls
    8.5 KB · Affichages: 36
  • Classes.xls
    8.5 KB · Affichages: 37

Discussions similaires

Réponses
12
Affichages
326

Statistiques des forums

Discussions
312 895
Messages
2 093 382
Membres
105 713
dernier inscrit
Karimov