Microsoft 365 Naissances avant et après 1900

JPC33

XLDnaute Junior
Bonjour à tous
Est-ce possible d'adapter les formules de JHA de la colonne 'L' avec aujourdhui() ?
Je cherche une formule standard adaptée pour un tableau avec des naissances avant et après 1900.
Certains sont décédés d'autres pas.
Merci
 

Pièces jointes

  • AGE JHA.xlsm
    15.8 KB · Affichages: 5
Solution
Bonjour,

Pourquoi utilises-tu des textes et non des dates ?
Est-ce obligatoire ? Est-ce à cause des dates antérieures à 1905 ?
Bonjour TooFatBoy
Comme je ne sais pas comment faire toute proposition est bonne à prendre. J'avais trouvé cela sur un forum justement pour pallier les dates antérieures à 1900.
Merci
Bonjour,

Peut-être ceci :
Code:
=SI(J2="";"";DATEDIF(J2;SI(K2="";MOIS.DECALER(AUJOURDHUI();1200);K2);"y"))
Grand merci TooFatBoy c'est impeccable
Bonne journée

JPC33

XLDnaute Junior
Bonjour,

Pourquoi utilises-tu des textes et non des dates ?
Est-ce obligatoire ? Est-ce à cause des dates antérieures à 1905 ?
Bonjour TooFatBoy
Comme je ne sais pas comment faire toute proposition est bonne à prendre. J'avais trouvé cela sur un forum justement pour pallier les dates antérieures à 1900.
Merci
Bonjour,

Peut-être ceci :
Code:
=SI(J2="";"";DATEDIF(J2;SI(K2="";MOIS.DECALER(AUJOURDHUI();1200);K2);"y"))
Grand merci TooFatBoy c'est impeccable
Bonne journée
 

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
313 276
Messages
2 096 760
Membres
106 744
dernier inscrit
sshkm16