Moyenne dans une colonne

  • Initiateur de la discussion Captain
  • Date de début
C

Captain

Guest
Je cherche à faire une moyenne de valeurs contenues dans une même colonne, mais sans prendre en compte les cellules non encore renseignées.
Exemple :
- Jai une colonne de 30 lignes. Seules les 10 premières sont renseignées donc j'ai besoin de la moyenne sur ces 10 valeurs. Par contre, lorsque je remplerai les lignes 11,12,13,14,15 ..... etc .... il faut que le calcul de ma moyenne tienne compte des nouvelles valeurs renseignées.

D'avance merci pour votre aide. :)
 

Monique

Nous a quitté
Repose en paix
Bonjour,

La fonction Moyenne() ne tient pas compte des cellules vides.

Si les cellules sont vides (ou contiennent du texte) à partir de A11, la formule
=MOYENNE(A1:A100)
te renvoie la même chose que
=MOYENNE(A1:A10)
 

Christophe

XLDnaute Occasionnel
Bonjour Monique, Captain,

J'imagine que le pb de Captain vient des cellules à 0 qu'il souhaiterait exclure du calcul.
Si tel est le cas, le pb peut être contourné par la fonction 'countif' (j'ai excel en anglais) qui doit être en français 'comptesi' j'imagine.

Cf fichier joint.

Bonne journée. [file name=moyenne_20050805114304.zip size=1621]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/moyenne_20050805114304.zip[/file]
 

Pièces jointes

  • moyenne_20050805114304.zip
    1.6 KB · Affichages: 15

Statistiques des forums

Discussions
312 841
Messages
2 092 708
Membres
105 514
dernier inscrit
Hébera