Mise en forme conditionnelle

YANOU

XLDnaute Junior
Bonjour.
J'ai une feuille avec une cellule B2 ou je retrouve soit le mot "Rien" soit tout autre texte
Sur la cellule C2, cette formule =SI(B2="Rien"," ";B2)
Sur cette cellule C2, je fais une mise en forme conditionnelle pour que le contour de la cellule soit supprimé si j'ai "Rien" => Appliquer une mise en forme uniquement aux cellules qui contiennent / Texte spécifique / contenant / un espace.
Si dans ma cellule B2 j'ai "Rien", la cellule C2 perd bien son contour.
Si dans ma cellule B2 j'ai "XY", la cellule C2 garde son contour.
Par contre si dans ma cellule B2, j'insère un espace entre X et Y, la cellule C2 perd son contour.
Dès que j'ai un espace dans la cellule B2, la mise en forme ne suit pas (?)
Merci pour votre aide.
 

Efgé

XLDnaute Barbatruc
Bonjour YANOU

Il est toujours mieux de fournir un petit classeur exemple, cela évite de devoir le faire pour répondre...
Sinon, pour ton problème:
Si tu écris "X Y"" en $B$2 la cellule $C$2 contient "X Y", donc la cellule $C$2 Contient un espace.
Pour que la mise en forme que tu attends soie bonne, il faut passer par
Mise en forme conditionnelle / Utiliser une formule
La formule est = C2<>" "
Cela ne prendra en compte que les valeurs non strictement égales à " " (espace)
Voir l'exemple construit selon tes indications.

Cordialement

EDIT: Bonjour JHA :)
 

Pièces jointes

  • YANOU.xlsx
    8.9 KB · Affichages: 38

YANOU

XLDnaute Junior
Re-Bonjour.
En fait, pour détourner le problème de l'espace, j'ai mis 2 espaces dans ma formule (un cas que je ne retrouve jamais).
Efgé, je n'arrive pas à utiliser ta solution <> dans la mise en forme conditionnelle.
Je suis novice dans l'utilisation de ces mises en forme.
Merci.
 

Pièces jointes

  • YANOU.xlsx
    14.1 KB · Affichages: 34

Efgé

XLDnaute Barbatruc
Re
Etape 1
upload_2016-10-26_11-2-5.png


Etape 2
upload_2016-10-26_11-3-25.png


Cordialement
 

Discussions similaires

Statistiques des forums

Discussions
312 894
Messages
2 093 379
Membres
105 712
dernier inscrit
CARLO 82