Mise à jour des liens vers une feuille ne se fait pas

Nallawenn

XLDnaute Nouveau
Bonjour,

J'utilise régulièrement un logiciel statistique (STATA) pour exporter les résultats de calculs (régressions économétriques) vers une feuille masquée 'results' d'un fichier excel. Je créée ensuite une seconde feuille 'table' dans mon fichier excel, j'y créée un joli tableau proprement mis en forme et je fais ensuite des liens depuis ma feuille 'table' vers ma feuille masquée 'results' pour afficher les résultats dans mon tableau.
Ceci me permet de pouvoir très facilement modifier les paramètres de mes calculs statistiques afin d'obtenir facilement plein de variation de mon tableau sans avoir a refaire systématiquement une fastidieuse mise en forme des résultats : je n'ai qu'à exporter de nouveaux résultats dans la feuille 'results' et mon joli tableau de l'onglet 'table' se met automatiquement à jour à l'ouverture du fichier. J'ai des centaines de fichiers excel construits ainsi et tout fonctionnait très bien jusqu'à présent.
Or, depuis quelques jours cela ne fonctionne plus : la feuille 'table' ne met plus à jour automatiquement mes liens vers la feuille 'results' et les résultats qui s'affichent sont faux.
Pour que ce soit plus clair, je joins un petit fichier 'test.xlsx' avec un onglet 'table' qui comporte 2 liaisons vers la feuille 'results' afin d'afficher les chiffres 66 et 32. Or vous pourrez constater que les liaisons ne sont pas à jour et ce sont d'autres chiffres qui s'affichent dans mon tableau (56 et 85). Pour que les bons chiffres s'affichent, je dois cliquer dans chacune des cellules, placer mon curseur dans la barre de formule et appuyer sur 'entrée'. Même la touche F9 ne fonctionne pas.
Toutes les solutions que j'ai trouvées en ligne (mettre le format des cellules sur standard, activer le calcul automatique des formules) ne fonctionnent pas et vu le nombre de fichiers excel et le millier de lignes de tableau que j'ai construit ainsi, je commence à désespérer..

D'avance, merci infiniment,
 

Pièces jointes

  • test.xlsx
    10.2 KB · Affichages: 27

Nallawenn

XLDnaute Nouveau
Bonjour,

Merci infiniment pour cette réponse rapide et cette solution qui fonctionne parfaitement. J'ai juste à faire un ctrl+h en remplacant tous les "=" en "= ".
Simplement, j'ai vraiment des dizaines de fichiers à plusieurs dizaines d'onglets dans ce cas et c'est très fastidieux.. De plus, avant j'arrivais parfaitement à exporter mes résultats dans une feuille et les liens vers cette feuille se mettaient systématiquement à jour à l'ouverture du fichier. Auriez-vous une idée de pourquoi ça ne fonctionne plus ? Est-ce qu'il y a eu une mise à jour d'Excel ou quelque chose de ce type ?

Merci beaucoup pour votre temps,
 

Nallawenn

XLDnaute Nouveau
Merci à nouveau pour cette réponse rapide, je n'utilise pas de tableaux structurés mais de simples liens vers des feuilles masquées (et je mets régulièrement à jour ces feuilles avec un logiciel statistique). J'utilise Excel 2016 mais j'ai aussi ouvert mes fichiers avec Excel 2007 et le problème est le même : la mise à jour des liens intra-classeur ne se fait pas automatiquement à l'ouverture du fichier.
 

Nallawenn

XLDnaute Nouveau
Oui, ça me semble être un problème vraiment étrange... C'est d'autant plus bizarre que ça fait des années que je travaille avec des liens intra-classeur et je n'ai jamais rencontré de problèmes. J'arrive toutefois à avancer pour aujourd'hui en utilisant votre solution (merci beaucoup !) mais ça n'est pas viable à plus long terme. J'en appelle donc aux grand.e.s manitou.e.s de ce forum ! :)

Merci encore,
 

Discussions similaires

Statistiques des forums

Discussions
313 239
Messages
2 096 474
Membres
106 637
dernier inscrit
jpdupont