méga formule de recherche

Batiscaf

XLDnaute Occasionnel
Bonjour tout le monde,

Là je ne sais pas comment faire pour ma formule.
Dans le formulaire qui est sur le second onglet, dans la partie que j'ai mis en jaune, j'ai besoin de remonter ce qui équivaut à l'entete des colonnes concernées du 1er onglet.
J'ai essayé avec les fonctions somme prod puis index mais je ne suis pas assez calé.
Pourriez vous m'aidez s'il vous plaît ?

Par la suite j'aurai besoin de remonter ce formulaire dans une fusion word pour les 170 participants, mais je ne sais pas si c'est du domaine de ce forum xl.
Prenons les problème dans l'ordre : déjà la formule.

Merci de votre aide.

Batiscaf.
 

Pièces jointes

  • Liste Speed Meeting.zip
    62 KB · Affichages: 64

Tibo

XLDnaute Barbatruc
Re : méga formule de recherche

Bonjour,

Avec utilisation de la fonction DECALER, associée à INDEX et EQUIV :

en G6 :

Code:
=SI(ESTNA(EQUIV(D6;DECALER('Meeting allocations'!$A$2;
EQUIV($C$3;'Meeting allocations'!$A$3:$A$181;0);;;28);0));"";
INDEX('Meeting allocations'!$A$1:$AC$1;EQUIV(D6;
DECALER('Meeting allocations'!$A$2;EQUIV($C$3;'Meeting allocations'!
$A$3:$A$181;0);;;28);0)))

à recopier vers le bas

@+
 

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : méga formule de recherche

Bonsoir,


=SI(ESTNA(EQUIV(D6;DECALER('Meeting allocations'!$A$2;EQUIV(C$3;Noms;0);;1;30);0));"";INDEX(titres;EQUIV(D6;DECALER('Meeting allocations'!$A$2;EQUIV(C$3;Noms;0);;1;30);0)-5))

Noms de champ
Noms ='Meeting allocations'!$A$3:$A$181
titres ='Meeting allocations'!$F$1:$AC$1


JB
 

Batiscaf

XLDnaute Occasionnel
Re : méga formule de recherche

Bonjour tout le monde,

Désolé Boisgontier j'avais pas vu ta soluce.

Voici la suite de mon problème : Finalement je n'ai pas à passer les données dans une fusion excel mais j'ai besoin d'éditer les 179 fiches à la suite comme dans le document joint.
J'ai un peu progressé mais mon problème est que je n'arrive pas à adapter la formule de base à partir du second participant. Je dois avoir un problème dans le DECALER ou l'EQUIV.

J'ai indiqué dans la colonne I ce que j'ai besoin de voir affiché dans la colonne G, à partir du second cartouche.

Merci de votre aide.

Batiscaf.
 

Pièces jointes

  • CF08Sm20080415.zip
    70.1 KB · Affichages: 41

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : méga formule de recherche

Bonjour,

En G4:

=SI(ESTNA(EQUIV(D4;DECALER('Meeting allocations'!$A$2;EQUIV(DECALER($C$2;ENT((LIGNE()-4)/25)*25;0);Noms;0);;1;28);0));""; INDEX(Titres;EQUIV(D4;DECALER('Meeting allocations'!$A$2;EQUIV(DECALER($C$2;ENT((LIGNE()-4)/25)*25;0);Noms;0);;1;30);0)-5))

Noms de champ:

Noms ='Meeting allocations'!$A$3:$A$250
Titres ='Meeting allocations'!$F$1:$AD$1



JB
 

Statistiques des forums

Discussions
311 997
Messages
2 084 452
Membres
102 580
dernier inscrit
DESIRE PATRICK