XL 2010 Insérer un caractère spécial dans un Label

Magic_Doctor

XLDnaute Barbatruc
Bonsoir,

Je bataille pour tenter d'insérer un caractère spécial dans un Label.
Dans une cellule, pas de problème, en revanche dans un Label le réultat n'est pas celui escompté.

Si j'écris dans une cellule nommée "Titre_UXvsUY" :
VB:
[Titre_UXvsUY] = "1 UY " & ChrW(&H225F)
Cela me renvoie bien : 1 UY ≟

Maintenant, j'écris pour un Label (ActiveX dans la feuille et non pas dans un UF) nommé "LabelUXUY1" :
VB:
ActiveSheet.LabelUXUY1.Caption = "1 UY " & ChrW(&H225F)
Ça me renvoie : 1 UY ?

Parfois on a envie de donner un coup de pied dans la machine...
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Magic_Doctor, Katido,
Moi, j'ai plus rigolo.
Si sur ActiveX Label sur feuille j'exécute :
VB:
Sub init()
    ActiveSheet.Label1.Caption = "1 UY " & "   " & ChrW(8771) & "   " & ChrW(8799)
End Sub
Il affiche 1 UY ? ?, MAIS si je clique dessus l'affichage est correct :
20220725_001638.gif

😅😂🤣 Evidemment je n'ai pas d'explications. ( Je suis sous XL2007 VBA 6.3 )
Si vous voulez essayez, voir PJ.
 

Pièces jointes

  • Bizarre.xlsm
    17.4 KB · Affichages: 3

Magic_Doctor

XLDnaute Barbatruc
Bonsoir sylvanu,

Merci pour votre collaboration.
J'ai vu la PJ. En effet, c'est bizarre, même très bizarre. Et le mot n'est pas fort !
Décidément, les ActiveX d'Excel ont dû être élaborés par un mec sous LSD payé au lance-pierre...
Bon, en attendant, à part obtenir un résultat, disons, folklorique, c'est pas possible.
 

Discussions similaires

Statistiques des forums

Discussions
313 313
Messages
2 097 043
Membres
106 816
dernier inscrit
Garry972