XL 2019 Historique, affichage antichronologique des sorties

mam721

XLDnaute Junior
Bonjour à tous,

Je coince sur une formule excel pour afficher l'historique de sortie mais dans un ordre antichronologiue. Et plus particulièrement lorsque qu'il n' y a pas beaucoup de sortie.

Dans l'onglet ETAT, j'ai un listing des sorties :
  • Date de sortie
  • Code
  • Oeuvres
  • Adhérent
  • Matricule
  • Date de retour

Dans l'onglet Historique:
J'ai 2 parties, une partie historique Œuvre et une partie Historique Adhérent

Dans la partie Oeuvre :
Lorsque je tape le code d'une oeuvre (M007) qui sort beaucoup j'ai bien les 14 dernières sorties. cependant lorsqu'il s'agit d'une œuvre avec peu de sortie (M008), il répète la dernière ligne trouvé sur le reste du tableau.
J'aimerais que les lignes répétées ne soit pas affichées ( vides).
Voici la formule en matricielle que j'ai utilisée:
Code:
=SI(C5="";"";
SIERREUR(
INDEX(ETAT!$E$1:$E$99;
MAX(
SI(ETAT!$B$1:$B$99=$C$5;
LIGNE(ETAT!$E$1:$E$99)-MIN(LIGNE(ETAT!$E$1:$E$99))+1
);
LIGNES($1:2)
)
);
""
))

Dans la partie Adhérent:
J'ai un problème similaire, mais aussi il ne m'affiche pas la première ligne :
Code:
=SI(J5="";"";
SIERREUR(
INDEX(ETAT!$B$1:$B$99;
MAX(
SI(ETAT!$E$1:$E$99=$J$5;
LIGNE(ETAT!$B$1:$B$99)-MIN(LIGNE(ETAT!$B$1:$B$99))+1
);
LIGNES($1:2)
)
);
""
))

et enfin j'aimerais afficher le nombre de jours qu'une oeuvre a été empruntée dans l'onglet Entree-Sortie
Pour cela je souhaiterais le comparer par rapport à la dernière sortie de l'oeuvre et de compter combien de jours il y a jusqu'a la date du jour.
Code:
=SI(I5="";"";AUJOURDHUI()-MAX(SI(ETAT!$B:$B=I5; ETAT!$A:$A)))

Je vous remercie pour votre aide.
 

Pièces jointes

  • fichier.xlsx
    357.6 KB · Affichages: 4

mam721

XLDnaute Junior
Bonjour Lolote83,

Merci pour ton retour et ta proposition.


Pour mon problème 1 :

Cependant, je souhaiterais maintenir une vision anti chronologique de la liste. (c’est-à-dire la plus récente sortie en premier vers la plus ancienne). Ta proposition affiche la liste des sorties mais dans un ordre chronologique (du plus ancien vers le plus récent).
Ma tentative affiche bien du plus récent vers le plus vieux. Exemple avec M007.
Mais lors qu’il y a peu de sortie, Exemple M008. Il m’affiche plusieurs fois la dernière ligne trouvée. J’aimerais que les lignes en doublons n’apparaissent pas.

J’ai mis des détails dans l’onglet Problème pour illustrer.

Serait il possible de modifier ta proposition?

Pour mon problème 2 :

Même problématique avec l’ordre des lignes.


Pour mon problème 3 :

J'aimerais afficher le nombre de jour depuis sa dernière sortie. Exemple M007, la dernière sortie est le 13/05 quelle est le nbr de jours entre le 13/05 et aujourd'hui ?


Je te remercie.
 

Pièces jointes

  • fichier.xlsx
    369.3 KB · Affichages: 6

Lolote83

XLDnaute Barbatruc
Bonjour,
Désolé pour le retard.
Concernant le problème 1 et 2
Dans mes formules, remplacer PETITE par GRANDE, je pense que cela devrait le faire
Concernant le problème 3
Je pense que ta formule est bonne, il suffit simplement de choisir le bon format d'affichage (Standard) par exemple)
Merci pour ton retour si OK
@+ Lolote83
 

Discussions similaires

Statistiques des forums

Discussions
313 192
Messages
2 096 070
Membres
106 486
dernier inscrit
Barklem