Autres Formule : Sommeprod ou Somme.Si avec recherche d'un mot (et non suite de caractères)

zebanx

XLDnaute Accro
Bonjour le forum

J'essaye par formule d'utiliser somme.si ou sommeprod en recherchant à sommer sur le mot "EO" (pour l'exemple ici).
Mais les lettres "EO" étant repris sur un autre mot "VALEO", le calcul est faux.

Pourriez-vous corriger les formules utilisées (Somme.si et Sommeprod...ou en apporter d'autres d'ailleurs!) s'il vous plait ?
SOMME.SI($A$2:$A$14;"*"&D3&"*";$B$2:$B$14) --> traite la chaine de caractères
SOMMEPROD(--ESTNUM(CHERCHE(D3;$A$2:$A$14));($B$2:$B$14)) --> traite la chaine de caractères
(bis) SOMME.SI($A$2:$A$14;D3&"*";$B$2:$B$14) --> ne traite pas les termes avant le mot recherché

Un petit fichier comme habituellement, plus "parlant".

Merci et bonne journée à tous
zebanx
 

Pièces jointes

  • sommeprod et sommesi.xlsm
    12.9 KB · Affichages: 13

JHA

XLDnaute Barbatruc
Bonjour à tous,

Pas sur que cela te convient mais à tout hasard
VB:
=SOMME(SI(SUBSTITUE(SUBSTITUE($A$2:$A$13;" …";"");"… ";"")=$D2;$B$2:$B$13))

Edit: bonjour Jocelyn :)

JHA
 

Pièces jointes

  • sommeprod et sommesi.xlsm
    14.7 KB · Affichages: 5

zebanx

XLDnaute Accro
Bonjour Jocelyn ;) et JHA ;)

@Jocelyn
Super formule qui fonctionne bien. Ce n'est pas si simple finalement !

@JHA
Bonne idée. Ca pose problème quand la chaine est différente de "...".

Je suis content d'avoir eu déjà et si rapidement un retour de 2 des meilleurs spécialistes de l'utilisation de ce type de formules du forum.:cool:
Ce n'est pas un cas trop fréquent mais il est presque dommage qu'excel ne dispose pas, sauf oubli, d'une formule comme "MOT()" qui permettrait de traiter ce type de problématique.

Bonne journée à tous les deux et encore MERCI
zebanx
 

Discussions similaires

Statistiques des forums

Discussions
313 195
Messages
2 096 101
Membres
106 495
dernier inscrit
dylan.44