XL 2013 Formule si aucune info =rien

maval

XLDnaute Barbatruc
Bonjour
J'ai une formule comme ceci:
=INDEX($C$7:$C$64;EQUIV($M7;$B$7:$B$94;0))
Qui fonction quand je rentre aucune valeur j'ai ceci #N/A comment je peut avoir une cellule vide

Je vous remercie d'avance
 

Etoto

XLDnaute Barbatruc
Bonjour
Je te remercie mais j'ai deux autre formules comme ceci
=INDEX($D$7:$D$64;EQUIV($M7;$B$7:$B$64;0))
=INDEX($B$7:$B$64;EQUIV(GRANDE.VALEUR($H$7:$H$64;LIGNE()-6);$H$7:$H$64;0))
je te remerci
Toujours la même chose,

VB:
=SIERREUR(INDEX($D$7:$D$64;EQUIV($M7;$B$7:$B$64;0));"")
Code:
=SIERREUR(INDEX($B$7:$B$64;EQUIV(GRANDE.VALEUR($H$7:$H$64;LIGNE()-6);$H$7:$H$64;0));"")

Tu places dedans un SIERREUR avec comme dernière variable ""
;)
 

fanch55

XLDnaute Barbatruc
Bonjour à tous,
Pour solutionner provisoirement un des problèmes, mettre en colonne H de la table, la formule suivante :
=SI(NB($E7:$G7)=0;"";SOMME($E7:$G7))

@Etoto a bien répondu à vos demandes telles qu'elles ont été posées.

Cependant, si je peux me permettre,
il vaut mieux tenter de résoudre une erreur avant de l'ignorer comme le fait SiErreur ...

Si j'ai bien compris, le tableau2 est le tableau1 trié par meilleur score .
les formules ne sont pas les plus indiquées pour des scores identiques .

Le classeur avec une macro automatique :
 

Pièces jointes

  • Copie de Classeur formules-3.xlsm
    29.4 KB · Affichages: 4

Discussions similaires

Statistiques des forums

Discussions
299 914
Messages
1 980 042
Membres
206 963
dernier inscrit
julien183645