formule récalcitrante

etigi

XLDnaute Junior
Bonjour, je suis en panique, j'ai un dossier à finir pour demain,
mais cette formule

=SOMMEPROD((Enregistr2!$D$2:$D$4993=$E8)*((Enregistr2!$AU$2:$AU$4993>DATEVAL("31/12/2012"))*((Enregistr2!$AU$2:$AU$4993<DATEVAL("01/02/2013"))*(ESTNUM(TROUVE("loyer";Enregistr2!$AS$2:$AS$4993))*(Enregistr2!$AW$2:$AW$4993)))))

ne marche pas à chaque fois.

Elle fonctionne parfaitement avec certain locataire et pas avec d'autres.
au secours,
si l'un de vous avait 5mn à me consacrer
merci
 

etigi

XLDnaute Junior
Re : formule récalcitrante

=SOMMEPROD((Enregistr2!$D$2:$D$4993=$E8)*((Enregis tr2!$AU$2:$AU$4993>DATEVAL("31/12/2012"))*((Enregistr2!$AU$2:$AU$4993<DATEVAL("01/02/2013"))*(ESTNUM(TROUVE("loyer";Enregistr2!$AS$2:$A S$4993))*(Enregistr2!$AW$2:$AW$4993)))))
 

JCGL

XLDnaute Barbatruc
Re : formule récalcitrante

Bonjour à tous,

N'aurais-tu pas quelques parenthèses en trop :
Code:
=SOMMEPROD((Enregistr2!$D$2:$D$4993=$E8)*(Enregistr2!$AU$2:$AU$4993>DATEVAL("31/12/2012"))*(Enregistr2!$AU$2:$AU$4993<DATEVAL("01/02/2013"))*ESTNUM(TROUVE("loyer";Enregistr2!$AS$2:$AS$4993))*Enregistr2!$AW$2:$AW$4993)

Il est vrai que sans fichier pas facile de tester...

A + à tous
 

Discussions similaires

Statistiques des forums

Discussions
312 798
Messages
2 092 219
Membres
105 293
dernier inscrit
Hélène Power