Formule personnalisée (jour-heure-minute-seconde)

marcelio

XLDnaute Occasionnel
Bonjour à tous,

N'ayant pas trouver de solution à mon problème dans ma recherche,je viens vers vous pour m'aider.
Dans ma celulle j'ai 33:10:20 qui correspond à 33heures 10minutes et 20secondes.
Je voudrais avec une formule personnalisée qui me transforme en:
jour - heure - minute - seconde (1jour 9heures 10minutes 20secondes)

Je vous remercie d'avance de votre aide

Marcelio
 

ROGER2327

XLDnaute Barbatruc
Re : Formule personnalisée (jour-heure-minute-seconde)

Bonjour à tous
Essayez :
Code:
[COLOR="DarkSlateGray"][B]=SI(ENT(A1);ENT(A1)&" jour"&SI(ENT(A1)>1;"s ";" ");"")&SI(ENT(24*MOD(A1;1));ENT(24*MOD(A1;1))&" heure"&SI(ENT(24*MOD(A1;1))>1;"s ";" ");"")&
SI(MOD(ENT(1440*MOD(A1;1));60);MOD(ENT(1440*MOD(A1;1));60)&" minute"&SI(MOD(ENT(1440*MOD(A1;1));60)>1;"s ";" ");"")&
SI(ARRONDI(MOD(86400*MOD(A1;1);60);2);ARRONDI(MOD(86400*MOD(A1;1);60);2)&" seconde"&SI(MOD(ARRONDI(86400*MOD(A1;1);2);60)>1;"s";"");"")[/B][/COLOR]
ROGER2327
#4034


Samedi 21 Phalle 137 (Erbrand, polytechnicien, ST)
14 Fructidor An CCXVIII
2010-W35-2T16:14:59Z
 
Dernière édition:

marcelio

XLDnaute Occasionnel
Re : Formule personnalisée (jour-heure-minute-seconde)

Merci beaucoup à vous 3
pour l'instant je vais prendre la solution de mth
mais je vais garder les autres près de moi

encore merci et bonne soirée à vous et au forum

Marcelio
 

ROGER2327

XLDnaute Barbatruc
Re : Formule personnalisée (jour-heure-minute-seconde)

Bonsoir à tous
Récapitulatif des propositions dans le classeur joint.​
ROGER2327
#4037


Dimanche 22 Phalle 137 (Dragonne, pyrophage, SS)
15 Fructidor An CCXVIII
2010-W35-3T02:01:04Z
 

Pièces jointes

  • Format_j-h-m-s_4037.xls
    18 KB · Affichages: 505

job75

XLDnaute Barbatruc
Re : Formule personnalisée (jour-heure-minute-seconde)

Bonjour marcelio, salut Mireille, kjin, Roger,

Récapitulatif des propositions dans le classeur joint.

A 4h du matin Roger est laconique, c'est normal :)

Il faut comprendre que dans un format Date "j" ou "jj" renvoient le numéro du jour dans le mois, et non pas la valeur entière de la date.

Si l'on veut utiliser le format de Mireille, il faut utiliser cette formule (fichier de Roger en B2) :

Code:
=ENT(D2)&TEXTE(D2;"-hh-mm-ss")

Mais la valeur renvoyée est évidemment un texte, ce n'est plus une date.

A+
 

Discussions similaires

Réponses
5
Affichages
291

Statistiques des forums

Discussions
299 845
Messages
1 979 512
Membres
206 755
dernier inscrit
So78310