Fonction recherchev inversé

cj welch

XLDnaute Occasionnel
Bonjour,

j 'aurais besoins d'aide avec la fonction recherchev car je n 'arrives pas a trouver la formule adapté a ma problèmatique.
voir fichier joint
merci par avance
 

Pièces jointes

  • KM.xlsx
    12.3 KB · Affichages: 36

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut être avec index()
Code:
=INDEX(données!$A$3:$A$11;EQUIV(ESSAI!$B9;données!$D$3:$D$11;0))
ou
Code:
=DECALER(données!$A$2;EQUIV(ESSAI!$B9;données!$D$3:$D$11;0);)

JHA
 

Pièces jointes

  • KM.xlsx
    12.5 KB · Affichages: 30

JCGL

XLDnaute Barbatruc
Bonjour à tous,

Peux-tu essayer :
Code:
=INDEX(données!$A$1:$A$10;EQUIV(ESSAI!$B9;données!$D$1:$D$10;0))

Où tu renseignes :
'=INDEX(la plage dans laquelle se trouve la valeur à trouver;EQUIV(la valeur cherchée;la plage dans laquelle se trouve cette valeur; 0))

A+ à tous

Edition : Salut JHA
 

eddy1975

XLDnaute Occasionnel
Bonjour,

j 'aurais besoins d'aide avec la fonction recherchev car je n 'arrives pas a trouver la formule adapté a ma problèmatique.
voir fichier joint
merci par avance

Bonsoir,

La fonction recherchev permet de rechercher une valeur de la gauche vers la droite. L'utilisation d'Index et Equiv permet de rechercher une valeur de la droite vers la gauche.
Voir l'exemple dans ton fichier. J'ai ajouter une liste déroulante sur la feuille données.
@+
Edit : Bsr JHA /JCGL
 

Pièces jointes

  • KM.xlsx
    13.6 KB · Affichages: 29

JHA

XLDnaute Barbatruc
Bonjour à tous,
Bonjour JCGL:), Eddy1975:)

Les données de ton tableau ne sont pas identiques tu dois mettre la formule en matricielle et insérer la fonction arrondi()
Code:
=INDEX(données!$A$3:$A$11;EQUIV(ESSAI!$B9;ARRONDI(données!$D$3:$D$11;2);0))
ou
Code:
=DECALER(données!$A$2;EQUIV(ESSAI!$B9;ARRONDI(données!$D$3:$D$11;2);0);)
 

Pièces jointes

  • KM.xlsx
    12.6 KB · Affichages: 37

cj welch

XLDnaute Occasionnel
bonjour a tous
merci pour votre aide
la formule DECALER fonctionne mieux que INDEX.
Par contre, je n 'arrives pas à la faire fonctionné dans mon tableau (j' ai #n/a qui s 'affiche dans la céllule)
pouvez vous me dire a quoi sert la ref $A$2 dans la formule DECALER

Merci
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je pense que tu as des "#N/A" car les valeurs ne sont pas identiques dans chaque tableau, c'est pour cela que j'ai inséré la fonction arrondi().
Attention, c'est une formule matricielle à valider par Ctrl+Maj+Entrée
Si tu ne veux pas utiliser la fonction arrondi, soit tu t'assures que les données sont semblables dans chaque tableau ou tu fais une liste déroulante des données du premier tableau.

JHA
 

Pièces jointes

  • KM.xlsx
    12.9 KB · Affichages: 29

cj welch

XLDnaute Occasionnel
hello,

rien a faire j 'ai toujours ce #N/A qui apparait.
Quand je modifie la formule
=SI($B9="";"";INDEX(données!A$3:A$11;EQUIV(ESSAI!$B9;données!$D$3:$D$11;0)))
et que je met 1 a la place du 0 en fin de formule, j 'ai un resultat qui est erroné
le tableau données est alimenté par un userform ainsi que la colonne nombre et prix unitaire de la feuille ESSAI
 

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 314
dernier inscrit
SABER ABD