Fonction recherche valeur dans un autre fichier

gourdin

XLDnaute Impliqué
Bonjour,

J'ai ouvert 2 fichiers : fichier1.xls et fichier2.xls

je souhaite avec la fonction "RECHERCHEV" placée dans une cellule du fichier1.xls rechercher une valeur qui se trouve dans la plage nommée "base" du fichier2.xls

J'utilise la formule suivante :

=RECHERCHEV(A1;fichier2.xls'!base;2;FAUX))

Mais cette formule ne fonctionne pas et ne doit donc pas être correcte.

Merci de votre aide
 

mth

XLDnaute Barbatruc
Re : Fonction recherche valeur dans un autre fichier

Bonjour gourdin,

A part la parenthèse en trop à la fin, je ne vois pas ?
Qu'est-ce qui ne fonctionne pas ? (joins quelques lignes des deux fichiers éventuellement, pour voir)

Bien à toi,

mth
Edit: avec quelques lignes sous le nez, on pourra voir si les données sont identiques, ou alors si on a une valeur comparée à du texte, ou autre)

Edit 2: :) bonsoir Hulk :)
 
Dernière édition:

Hulk

XLDnaute Barbatruc
Re : Fonction recherche valeur dans un autre fichier

Hello,

Je pense que c'est ta "base" qui doit avoir un problème..

Supposons que ta "base" est A1:B10 avec ceci, en tous cas chez moi, ça joue (je suis sur le "Classeur1.xls").
Code:
=RECHERCHEV(A1;[Classeur2.xls]Feuil1!$A$1:$B$10;2;0)
Ou comme ça..
Code:
=RECHERCHEV(A1;Classeur2.xls!base;2;0)
 
Dernière édition:

gourdin

XLDnaute Impliqué
Re : Fonction recherche valeur dans un autre fichier

En essayant de créer un fichier simplifié pour le forum je me rend compte que celà fonctionne.

Je vais donc revoir ce qui ne va pas dans le fichier original.

Désolé.

Merci à vous deux
 

Discussions similaires

Statistiques des forums

Discussions
299 706
Messages
1 978 621
Membres
206 308
dernier inscrit
thian