Microsoft 365 Fonction NB.SI.ENS

lolo_76

XLDnaute Nouveau
Bonjour à tous,

Je n'arrive pas à trouver la formule qui me permettrai de trouver sur l'année le nombre de jour qui affiche le produit "C", "A","P","PP" avec un affichage mois par mois et non sur l'année complète.

Merci de votre aide
 

Pièces jointes

  • Classeur1.xlsx
    21.3 KB · Affichages: 10

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Lolo,
En attendant mieux et plus simple, un essai en PJ avec :
VB:
=NB.SI.ENS($B$4:$NB$4;F$17;$B$1:$NB$1;">="&$E18;$B$1:$NB$1;"<"&MOIS.DECALER($E18;1))+
NB.SI.ENS($B$5:$NB$5;F$17;$B$1:$NB$1;">="&$E18;$B$1:$NB$1;"<"&MOIS.DECALER($E18;1))+
NB.SI.ENS($B$6:$NB$6;F$17;$B$1:$NB$1;">="&$E18;$B$1:$NB$1;"<"&MOIS.DECALER($E18;1))+
NB.SI.ENS($B$7:$NB$7;F$17;$B$1:$NB$1;">="&$E18;$B$1:$NB$1;"<"&MOIS.DECALER($E18;1))
 

Pièces jointes

  • Classeur1 (14).xlsx
    21.6 KB · Affichages: 3

Jacky67

XLDnaute Barbatruc
Bonjour à tous,

Je n'arrive pas à trouver la formule qui me permettrai de trouver sur l'année le nombre de jour qui affiche le produit "C", "A","P","PP" avec un affichage mois par mois et non sur l'année complète.

Merci de votre aide
Bonjour à tous,
Une proposition avec
VB:
=SOMMEPROD((MOIS($B$1:$NB$1)=MOIS(1&$A14))*($B$4:$NB$7=B$13))
 

Pièces jointes

  • LOLO_76).xlsx
    26.2 KB · Affichages: 12

Jacky67

XLDnaute Barbatruc
Bonjour J'ai essayé d'incorporer ton code sur mon fichier mais bizarrement je n'arrive pas à trouver les données voulus.

Merci encore de votre aide.
Re..

En B152
Code:
=SOMMEPROD((MOIS('B82500'!$V$6:$ABW$6)=MOIS(1&$A152))*('B82500'!$V$9:$ABW$17=B$151))
et recopier droite et bas
 

Pièces jointes

  • Copie1 V2.xlsm
    831.7 KB · Affichages: 1
Dernière édition:

lolo_76

XLDnaute Nouveau
Re..

En B152
Code:
=SOMMEPROD((MOIS('B82500'!$V$6:$ABW$6)=MOIS(1&$A152))*('B82500'!$V$9:$ABW$17=B$151))
et recopier droite et bas
Merci Jacky de ton retour, mais le problème est que quand j'intègre ton code, les données sont erronées.
J'explique, pour mon tableau une date est représentative de 2 cases

1638240961319.png


Donc normalement avec ton code, de devrais trouver 1 comme 1 journée complète si "PP" est mis sur les 2 cases à la suite. Et si seulement il y à 1 seul "PP" le code devrait trouvé 0,5.

As-tu une idée ?

Merci encore de ton aide
 

Jacky67

XLDnaute Barbatruc
Merci Jacky de ton retour, mais le problème est que quand j'intègre ton code, les données sont erronées.
J'explique, pour mon tableau une date est représentative de 2 cases

Regarde la pièce jointe 1123319

Donc normalement avec ton code, de devrais trouver 1 comme 1 journée complète si "PP" est mis sur les 2 cases à la suite. Et si seulement il y à 1 seul "PP" le code devrait trouvé 0,5.

As-tu une idée ?

Merci encore de ton aide
Re..
Ben.....si chaque case trouvée vaut 0.5 tu divises le résultat de la formule par 2, non??
Code:
=SOMMEPROD((MOIS('B82500'!$V$6:$ABW$6)=MOIS(1&$A152))*('B82500'!$V$9:$ABW$17=B$151))/2
 

Pièces jointes

  • Copie1 V2.xlsm
    831.4 KB · Affichages: 7
Dernière édition:

Statistiques des forums

Discussions
312 926
Messages
2 093 672
Membres
105 781
dernier inscrit
Dominique G.