Filtre et sous.total conditionné

Coyote

XLDnaute Junior
Bonjour,

J'ai préparé un calendrier avec en colonne les agents de ma société.

Chaque semaine, on suit un registre de présence avec la légende suivante saisie dans la colonne de l'agent concerné.

P pour présent
C pour congés
M pour arrêt maladie
etc...

Le calendrier est éventuellement filtré par semaine

Je souhaiterai compté le nombre de P, C, M par agent selon le filtre appliqué en bas de tableau

La formule SOUS.TOTAL ne semble pas efficace, elle ne distingue pas les P, C et M.
La formule NB.SI ne tiendra pas compte du filtre

Peut-être avec la formule SOMMEPROD mais comment définir le critère valeur affiché à l'écran ?

ou autre solution sans VB



Ci-joint un extrait de mon tableau

ATTENTION fichier compressé avec WINRAR et extension renommée en ZIP pour pouvoir l'uploader sur le forum

DONC après récupérer renommer extension en RAR pour l'exploiter



D'avance merci pour les solutions qui seront apportées


Amitiés

Luc
 

Pièces jointes

  • cal.zip
    21.1 KB · Affichages: 59
  • cal.zip
    21.1 KB · Affichages: 69
  • cal.zip
    21.1 KB · Affichages: 65

Coyote

XLDnaute Junior
Re : Filtre et sous.total conditionné

Merci JB

Je tatonne en combinant avec un exemple présenté dans ton lien


avec la formule

=SOMMEPROD((SOUS.TOTAL(2;DECALER($C$3;LIGNE(3:744)-3;0)))*(D$3: D$744=$C750))

Elle fonctionne sur la 1ère colonne mais pas les suivantes


Par contre j'avoue ne pas la comprendre

Encore moins la formule INDIRECT


Total respect

Amitiés

Luc
 
Dernière édition:

JCGL

XLDnaute Barbatruc
Re : Filtre et sous.total conditionné

Re,

Tu as oublier les $ LIGNE(3:744)
Code:
=SOMMEPROD((SOUS.TOTAL(9;DECALER($C$3;LIGNE(3:744)-3;0)))*(D$3:D$744=$C750))

au lieu de

Code:
=SOMMEPROD((SOUS.TOTAL(9;DECALER($C$3;LIGNE($3:$744)-3;0)))*(D$3:D$744=$C750))

A+
 
Dernière édition:

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 827
Messages
2 092 557
Membres
105 451
dernier inscrit
mariane_lp