SOMMEPROD Planning et Comptage conditionnel

Sylvie

XLDnaute Accro
Bonjour Cher Forum,

j'aurai besoin de l'oeil averti et exercé de quelques formulistes pour m'aider à résoudre le problème suivant :
Dans le fichier joint, un planning présente les caractéristiques suivantes (je vous livre les dessous du décor ) :
- planning dynamique : changement du mois en A1
- mise en forme conditionnelle assortie (pour les fériés et WE)
- Macro me permettant d'associer la mise en forme conditionnelle avec la légende rappelée en ligne 27 (on tape la lettre adéquate et hop c'est magique )
- 1 feuille "paramètres" avec une zone nommée "jfériés"

Je souhaite en colonne AI pouvoir compter le nombre de cellules comportant la lettre C (la lettre minuscule "c" signifie 1/2j de congés, et la lettre majuscule signifie 1J de congés) dès lors que le jour de congé ne coïncide pas avec un samedi , dimanche (soit JOURSEM($C$2<5)) ou avec un jour férié (zone nommée "jfériés") (donc pour les seuls jours dits ouvrés).

Votre mission (si vous l'acceptez) serait donc de compléter ma formule en la colonne AI . (J'y parviens certes mais avec une formule à coucher dehors et je reste persuadée qu'il existe beaucoup plus simple mais je butte :confused:)

J'adapterais ensuite cette formule dans les colonnes AJ et AK au comptage du nombre de jours ouvrés de RTT (r ou R) ou de maladie (m ou M) et au cas des jours ouvrables (seuls Dimanche et fériés exclus)

Merci d'avance pour votre aide

Bonne journée à tous
 

Pièces jointes

  • Planning_XLD.xls
    73 KB · Affichages: 158

Tibo

XLDnaute Barbatruc
Re : SOMMEPROD Planning et Comptage conditionnel

Bonjour,

Pas certain d'avoir fait plus simple (bien au contraire).

Mais pas facile non plus de faire simple avec tous les critères :

en AI13 :

Code:
=SOMMEPROD(EXACT(C3:AG3;"C")*((JOURSEM($C$2:$AG$2;2)<6)-
ESTNUM(EQUIV($C$2:$AG$2;Paramètres!$A$2:$A$14;0))))+SOMMEPROD(
EXACT(C3:AG3;"c")*((JOURSEM($C$2:$AG$2;2)<6)-ESTNUM(EQUIV(
$C$2:$AG$2;Paramètres!$A$2:$A$14;0)))*0.5)

Bon app

@+
 

PascalXLD

XLDnaute Barbatruc
Modérateur
Re : SOMMEPROD Planning et Comptage conditionnel

Bonjour

Je me permets d'intervenir non pour la formule je suis trop nul mais pour faire une bise à Sylvie et lui dire que cela me ferait plaisir de la revoir le 4/5 octobre si c'est toujours OK

Bonne journée
 

tototiti2008

XLDnaute Barbatruc
Re : SOMMEPROD Planning et Comptage conditionnel

Bon, beaucoup plus lent que Tibo mais comme je l'ai faite :

Code:
=SOMMEPROD(EXACT(C3:AG3;"C")*(JOURSEM($C$2:$AG$2)<>1)*
(JOURSEM($C$2:$AG$2)<>7)*(NB.SI(Paramètres!$A:$A;$C$2:$AG$2)=0))
+SOMMEPROD(EXACT(C3:AG3;"c")*(JOURSEM($C$2:$AG$2)<>1)*
(JOURSEM($C$2:$AG$2)<>7)*(NB.SI(Paramètres!$A:$A;$C$2:$AG$2)=0))*0,5
 

Sylvie

XLDnaute Accro
Re : SOMMEPROD Planning et Comptage conditionnel

Bonjour Tibo, tototiti2008, Pascal, le forum

Merci beaucoup Tibo pour ta précieuse contribution . C'est Parfait ça marche !

Merci également tototiti2008 (on peut être en effet être en congé un samedi, jour ouvrable mais non ouvré ;)) Ta formule fonctionne également parfaitement

Quant à GO Pascal, c'est oui pour le 4/5 Oct.

Bonne journée à tous
 

ChTi160

XLDnaute Barbatruc
Re : SOMMEPROD Planning et Comptage conditionnel

Salut Sylvie
Bonjour le fil
Bonjour le Forum

arff avec un peu de retard Lol
voilà je me suis intéressé à ta demande en Aout , puis j'ai fait d'autres choses et aujourd'hui , je me dis pourquoi ne pas lui présenter , ce qui m'a permis de passer un bon moment , pour élaboré ce fichier .

je ne réponds pas exactement à la demande , mais ,ce fichier permet de gérer le planning tout en permettant de consulter les données par agent(mensuelles ou annuelles)
je n'ai pas mis de gestion du planning via les cellule A2 et B2 à voir Lol

On pourrait ajouter le transfère du décompte dans la feuille , mais bon à voir Lol

Je joins donc le fichier
Le Fichier :http://cjoint.com/?kvnRHq58np
Bonne fin de journée
 
Dernière édition:

Discussions similaires

Réponses
8
Affichages
286
Réponses
10
Affichages
2 K

Statistiques des forums

Discussions
313 320
Messages
2 097 137
Membres
106 848
dernier inscrit
toufk